Log in or register to post comments

Vuforia Unity support installer editor path bug

January 17, 2019 - 5:47am #1

Vuforia SDK Version: 8..0.10 -

Description with steps to reproduce: I tried to update Vuforia from 7.x to 8.x from the Vuforia Configuration ScriptableObject inspector.

My problem is that when I open the *.pkg I get this error:

"The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance."

I've examined the content of that *.pkg and I see a script pointing to "/Applications/Unity"

In our case that folder name it's different because we have multiple Unity editor versiones installed and it's what was causing that error.

Can you fix it on your end? Thanks. -

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: iOS -

Mobile Device Manufacturer and Model name: iPhone -

Do the Vuforia Sample Applications show the same behavior?:

Vuforia Unity support installer editor path bug

April 13, 2019 - 5:47am #5

Hi! I can solve this problem. Only you need to select the customize option in the installer, after that, you select the other option, on the destination button, and you need to select the folder with this name Unity_2018_(Version that you had installed on your machine) and you can install now the new vuforia package.

Vuforia Unity support installer editor path bug

February 1, 2019 - 9:19am #4

Hi,

During the installation, I selected the customized folder for the Unity version that I customized due to the Unity HubI and it worked.

Thanks

Vuforia Unity support installer editor path bug

January 18, 2019 - 2:18am #3

Hello,

Where are those instructions? Searching on Google I only get forum results not an official documentation page.

Also, I think that the error:

"The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance."

Doesn't help much finding the root cause that it's that I don't have a "Unity" folder under Applications. If we get more helpful error information we could fix it faster.

Vuforia Unity support installer editor path bug

January 17, 2019 - 8:58am #2

Hello,

To upgrade the version of Vuforia embedded in the Unity Editor, please follow these steps:

  1. Open the Unity Editor
  2. Select Window->Vuforia Configuration
    • If there is an error message about Vuforia not being enabled, please follow the instructions and restart this process
  3. If your version of Unity is eligible for a Vuforia update, you'll see a message and link to download the installer
  4. Download and extract installer executable from downloaded ZIP file
  5. Quit Unity Editor
  6. Run the installer executable
    • For Windows, select the folder that corresponds to the installed version of the Unity Editor that is eligible for the Vuforia update. Ex: C:\Program Files\Unity_2018.1.4f1
    • For Mac, select the drive
      • If the Unity installation you're upgrading
        • IS NOT in /Applications/Unity/, select "Customize" and change the Location to the desired folder
        • IS in /Applications/Unity/, select "Install" to complete the installation
  7. Restart the same version of the Unity Editor in Step #1
  8. Verify the update in the Unity Editor via Window->Vuforia Configuration

If you have any previously installed Vuforia samples, you'll also want to download the updated versions of those from the Asset Store.

Thanks,

Vuforia Engine Support

Log in or register to post comments