Topic locked

VUFORIA_SENSOR_FUSION

April 1, 2021 - 3:27am #4

Hi 

I'm trying to force Vuforia to use VISLAM for Ground Plane. 

I'm calling this method in Awake() : VuforiaRuntimeUtilities.SetAllowedFusionProviders(FusionProviderType.VUFORIA_SENSOR_FUSION); 

Strangely, it is forcing towards VUFORIA_VISION_ONLY. 

In fact, when i call VuforiaRuntimeUtilities.GetActiveFusionProvider() i get VUFORIA_VISION_ONLY, and can't use Ground Plane anymore. 

 

Why is it happening ? 

 

Thanks in advance 

VUFORIA_SENSOR_FUSION

April 2, 2021 - 4:19am #3

Hi,

In order to use VISLAM, the device needs to be calibrated by us.

Could you please let me know with which device you are trying to force VISLAM?

Alternatively you can FUSION_PROVIDER_PLATFORM_SENSOR_FUSION to use ARKit and ARCore.

Thank you.

Vuforia Engine Support

VUFORIA_SENSOR_FUSION

April 6, 2021 - 12:49am #2

Hi, 

the device is Xiaomi Mi Mix 2.

VUFORIA_SENSOR_FUSION

April 6, 2021 - 5:17am #1

Hi,

The device is not calibrated by us, so it does not have the VISLAM option.

I've also checked if its supported by ARCore and unfortunately it is not. https://developers.google.com/ar/discover/supported-devices. they started support with Mi Mix 2S.

You can only use Vuforia_Vision_Only with the device.

Thank you for your understanding.

Vuforia Engine Support

Topic locked