Topic locked

VWS Create Targets Broken

March 3, 2015 - 10:05am #13

Vuforia SDK Version: 4.0 and 3.X -
Description with steps to reproduce:

Our code for interacting with VWS has been working for months, but for the past couple of days, since the rollout of Vuforia 4.0, there has been a severe bug. Whenever we create a new target using the JSON API, we receive a response with a result code of TargetNameExist. The target names definitely do not exist. They include a new random UUID. If we examine the target database in the web browser, we see that the new targets are in fact being created, but the problem is that the resposne we receive with the faulty result code does not include the TargetId, so we have no handle to the target which our server can store.

Can you please look into this bug immediately. It is completely destroying the vision component of our app since we create new targets programmatically all the time.

Thanks,

Philipp Hertel

 

 

-
Development OS (Mac OS X, Windows, Linux): Mac, Windows, -
Mobile OS and Version: N/A -
Mobile Device Manufacturer and Model name: N/A -
Do the Vuforia Sample Applications show the same behavior?: Don't know.

VWS Create Targets Broken

March 4, 2015 - 12:35am #12

Hi,

could you also share the name of the Cloud Database affected by this issue ?

 

VWS Create Targets Broken

March 5, 2015 - 10:01pm #11

I tested a couple of VWS target uploads to a couple of different Cloud DBs and it worked okay. The targets may take some time to process, but the result_code was TargetCreated. The Target Manager also shows that the targets are processing. I uploaded a target named test1 to the "playmeAR" database and it worked. The target shows as Processing right now. I used the PostNewTarget.java sample app that we provide.

1. What region are you attempting to connect from?
2. Are all targets failing to upload or is it intermittent?
3. Have any VWS target uploads worked since 4.0 release last week?

 

VWS Create Targets Broken

March 6, 2015 - 12:41am #10
Hi,

Noticed your test1 and also we understand once accepted by the VWS it will come out as "processing" for now its not registering any uploads from our system. 
1. Southeast Asia (Malaysia)

2. All targets are failing to upload from our Web Management system that we created. 
3. A few did last week but last 2 days it stop working and we start to face this unable to upload through vws api problem.

PS: PostNewTarget.java ( we use postnewtarget.php and we built it in pre-vuforia 4.0 do you guys have a backward compatibility for the VWS api or is there some minor changes to the calling command so to avoid this problem. 

 

VWS Create Targets Broken

March 6, 2015 - 10:59am #9

Hi, it would be helpful to know what exactly you are sending (headers + message body) and what exactly you're getting as a response (http response code and message body).  The response should contain a transaction id.

 

VWS Create Targets Broken

March 9, 2015 - 5:41pm #8

The VWS API remains the same in 4.0. Is the problem still occurring?

VWS Create Targets Broken

March 9, 2015 - 7:41pm #7

Hi Alessandro and dm3d,

Thank you for the reply,

I see, because previously it was the name that should be unique, now it has a unique identifier does that mean i would have to add a new column which is uuid?

*I'll edit this once i get the header+message / response code*

 

 

VWS Create Targets Broken

March 9, 2015 - 8:04pm #6

VWS Create Targets Broken

March 10, 2015 - 7:46am #5

Hi Alessandro,

 

Previously uploading to vuforia was successfull but since the upgrade of the api we are having problems it keeps throwing error that says badImage.

Was looking at your documention you .jpg and .png and the file is not that big. 

 

Screenshot of the error message below.

http://gyazo.com/f8bd002328792bc314f142a4efed0a95

 

Thanks!

VWS Create Targets Broken

March 10, 2015 - 7:53am #4

Can you try to upload that same image using the Target Manager UI?

VWS Create Targets Broken

March 10, 2015 - 10:38pm #3

We've detected the problem, thanks to Vuforia Tech team, it was on our end whereby we uploaded the images with alpha channels. Everything is working fine. 

Thanks Alessandro and Dm3d! 

VWS Create Targets Broken

March 10, 2015 - 10:40pm #2

Dear Alessandro,

I share the same concern with Philip, as our system is facing the same json api problem with our make shift web management system. we could not upload any targets into the target manager via the VWS Api. Please check on this as we are having a presentation soon.

Thanks,
Alvin

VWS Create Targets Broken

March 11, 2015 - 12:51am #1

Glad to hear it ;-)

 

Topic locked