Topic locked

Webcam Play mode issue in Unity 4

January 4, 2013 - 6:56pm #1

Dear All,

I just started using Unity 4 + Vuforia for development and can't manage to test Webcam Play mode whilst I have activated the 30 days trial for the Pro version of Unity 4. The Play mode run I can see the framemarker but nothing else than white background around.

I still have the message in the AR Inspector : "Play mode require Unity Pro license!". I tried to troubleshoot and can't go any futher than qcarCheckNativePluginSupport() function that seems to throw an exception when called in webcameditor.cs. Can you please help me?

Many Thanks

Kev

Webcam Play mode issue in Unity 4

December 4, 2014 - 6:27am #30

Cheers-

Webcam Play mode issue in Unity 4

December 4, 2014 - 12:17am #29

this worked for me!

Webcam Play mode issue in Unity 4

September 5, 2014 - 5:33am #28

OK, thanks. This confirms that Vuforia is working with your Unity installation and license.

Perhaps Unity has cached some data about your original big project in some system/user directory and cannot get rid of it.

For example, the folders:

C:\Users\YOUR_USERNAME\AppData\Local

C:\Users\YOUR_USERNAME\AppData\LocalLow

C:\Users\YOUR_USERNAME\AppData\Roaming

contain a good bunch of cached data for Unity.

You should be able to fix this by selecting your full project Assets (i.e. selecting the "Assets" folder in the Editor) and export it as a Unity-package and then reimport it into a new project.  

 

 

Webcam Play mode issue in Unity 4

September 5, 2014 - 5:15am #27

AlessandroB wrote:

 I just created a new project and it worked.

Does this include the Image Targets sample package or other Vuforia package ? (or just a basic setup with a Vuforia ARCamera in the scene ?)

 

 

I didn't configure any markers for the test, I just dragged the ARCamera prefab into the scene, deleted the main camera and started it - So the ARCam was the only entity in this scene. The warning messege in the inspector was gone and also the WebCamStream was rendered.

Webcam Play mode issue in Unity 4

September 5, 2014 - 4:53am #26

 I just created a new project and it worked.

Does this include the Image Targets sample package or other Vuforia package ? (or just a basic setup with a Vuforia ARCamera in the scene ?)

 

Webcam Play mode issue in Unity 4

September 5, 2014 - 4:33am #25

Hi,

thanks for your reply. I just created a new project and it worked. Unfortunately my project is too large to move it into an empty project in an adequate time. 

Deleting the Library folder and let Unity recreate it didn't help. I also upgraded Unity to 4.5.3 now but the issue remains.

Webcam Play mode issue in Unity 4

September 5, 2014 - 4:05am #24

Have you tried creating a fresh New project and importing one of the Vuforia Samples ? does it happen also in that case ?

One recommendation when upgrading an existing project is shutdown Unity,  delete the entire Library folder from your project directory, then restart Unity (Unity will reload your project and will recreate a new Library folder automatically). This can help getting rid of potentially  incorrect / obsolete cached information in your project.

Also, note that PC Win 8 is not supported (Vuforia supports Windows 7 - 32 and 64 bit).

 

 

Webcam Play mode issue in Unity 4

September 5, 2014 - 3:35am #23

After working with Vuforia for a while now this issue occured here too on a PC Win 8, Unity 4.3.2.

When I started the project I had Unity Pro, Android Basic and iOS basic. Back then the Webcam worked properly while running the app in the editor but after I activated Android Pro and iOS Pro the dev mode stopped working and now it says 'Play mode requires a Unity Pro license'.

That's a bit confusing because now I have more Pro licenses than before and additionally I'm using Vuforia 3.0.9 (same with 3.0.6) for Unity what actually should also run in dev mode with Unity Free since 2.8 as read here: Vuforia Play Mode is available in the free version of Unity 4.3

Restarting Untiy didn't help unfortunately. Are there any further solutions?

Webcam Play mode issue in Unity 4

August 25, 2014 - 9:45pm #22

Hi Hi Hi

 

I has same issue but i did it 

 

you must have QCAR Plugins in "asset/Plugins"

 

"QCARWrapper bundle... dll... m..."

 

Oh I hope eng well 

Webcam Play mode issue in Unity 4

May 14, 2014 - 11:46pm #21

Hi There, 

 

Just comming back to say that I have resloved this issue by completely shutting down Unity3d 4.1 and then reloading.

 

This seems to gve me the web camera functionality back when testing on WIN

 

This also seemed to effect the issue of not being able to static and dynamic batch, the reload again fixing these issues.

 

regards, 

 

morph

Webcam Play mode issue in Unity 4

May 12, 2014 - 11:59pm #20

Hi There, 

 

I seem to be having the same issue, 

 

I have unity pro, ios and android and can't seem to get the webcamera to work for testing purposes. Just wondering if there has been a solution found?

Webcam Play mode issue in Unity 4

April 1, 2013 - 1:57am #19

Hello.

Has there been any progress with this issue? My collegue is having it, and we'd like to know if something can be done about it.

Thanks in advance for any advice.

Edit: Nevermind. We realized he's on Snow Leopard.

Webcam Play mode issue in Unity 4

February 26, 2013 - 3:12am #18

i dont want the webcam feature i just want it to work properly 

Webcam Play mode issue in Unity 4

February 25, 2013 - 6:51pm #17

You'll need a Pro license. The webcam feature is only supported on Unity Pro.

Webcam Play mode issue in Unity 4

February 25, 2013 - 3:41pm #16

im using unity 3.5.6 inde with ios licence and vuforia 2.0

 

Webcam Play mode issue in Unity 4

February 25, 2013 - 3:41pm #15

im using unity 3.5.6 inde with ios licence and vuforia 2.0

 

Webcam Play mode issue in Unity 4

February 25, 2013 - 3:40pm #14

no but i am, at runtim the clear flags resets to depth only - hence the whiteout.

this is killing my project.

Webcam Play mode issue in Unity 4

February 25, 2013 - 3:40pm #13

no but i am, at runtim the clear flags resets to depth only - hence the whiteout.

this is killing my project.

Webcam Play mode issue in Unity 4

February 25, 2013 - 9:42am #12

Thanks for the reply, I guess I will have to finally migrate to Lion....

 

Ludovic

Webcam Play mode issue in Unity 4

February 25, 2013 - 2:01am #11

Hi ludovic,

Sorry to say that Snow Leopard is not supported by Vuforia as a development environment.  You will need Lion or Mountain Lion.

thanks

Nalin

Webcam Play mode issue in Unity 4

February 24, 2013 - 7:07pm #10

I am on a mac running snow leopard, my license in the about unity appears correctly (Unity Pro) along the serial number that comes from studica (education license).

Ok I will send them an email, not sure if I could get the ticket number, if I do I will let you know.

Ludovic

Webcam Play mode issue in Unity 4

February 24, 2013 - 2:14pm #9

We're using conditional compilation. Which license version is acknowledged in the Help > About Unity panel?

Tell them that Unity is not detecting the correct license version. You can mention Vuforia, we work closely with Unity. If you send me the ticket number that they give you, I'll track it from our side as well. It would be good to figure out why this is occurring, because it's not coming from our SDK.

Webcam Play mode issue in Unity 4

February 24, 2013 - 11:22am #8

But what should I ask ? If I tell them it is a problem with vuforia they will probably tell me to ask you ? How do you check for the license so I can ask a more precise question. Is there a special call in the unity API for that ?

 

thanks

Ludo

Webcam Play mode issue in Unity 4

February 24, 2013 - 8:14am #7

Contact Unity support. I'd run into a similar issue because I have many Unity versions installed.

Webcam Play mode issue in Unity 4

February 23, 2013 - 2:55pm #6

Yes still trouble. I was never able to solve this licence issue with unity 4. Could it be because I have different version of unity installed ? should I try to unsinstall everything and start from fresh ?

Webcam Play mode issue in Unity 4

February 23, 2013 - 12:12pm #5

@ludovic are you still having problems?

Webcam Play mode issue in Unity 4

February 23, 2013 - 9:01am #4

Many Thanks. I tried and it fixes the issue.

Cheers.

Webcam Play mode issue in Unity 4

February 6, 2013 - 11:37am #3

Hi,

I have exactly the same problem, even from fresh new project, the web cam behavior just keep saying that I require the unity Pro version which I have. I try to restart unity, switch between platform it doesnt change a thing.

It work perfectly with unity v3.5.1f2 but not with v4.0.1f2

What should I do to make this feature available ?

Also did you have any plan to make this web cam behavior available for a build targetting PC or Mac ?

thanks in advance for your help, and again thanks for releasing such a great SDK for AR.

Ludo

This error can sometime occur

January 7, 2013 - 1:52pm #2

This error can sometime occur when you change the build target in build settings. So first, try restarting Unity. 

Is the FrameMarkers project from Vuforia 1.5 or 2.0? - if it's a 1.5 you'll want to migrate it to 2.0 - https://developer.vuforia.com/resources/dev-guide/migrating-your-unity-project

Also try creating a new project, importing only the extension, and testing from that context. 

Topic locked