Topic locked

Vuforia - Magic Leap Sample not working

March 11, 2021 - 4:44pm #1

Hi guys, 

I am a newbie XR dev trying to develop apps for Magic Leap 1 using Vuforia within Unity 2019.4.2f1 LTS and Unity 2020.2.3f1 and Vuforia Ver 9.7.5.

I decided to begin with compiling, building, deploying and running the sample projects given on the asset store to test out the Image Targets and Model Targets.

I was able to successfully compile and run the apps but the Image and Model Target recognition won't work and the app would never detect and place the sample assets on top of the real Image and Objects (The Astronaut and the Viking Rover).

I tried with both the versions of Unity and the sample projects as there are two versions on the asset store. I don't know where else to look for logs or related info. Anyone else experience the issue? Any help here would be greatly appreciated. 




Vuforia - Magic Leap Sample not working

March 12, 2021 - 2:43pm #3

I had added that. I recently upgraded to Magic Leap XR plugin 6.2.2 and it worked. 

Thanks for your time :)

Vuforia - Magic Leap Sample not working

March 12, 2021 - 1:24am #2


Could you please confirm that you also added a license?

Article goes over how to do it:

Thank you.

Vuforia Engine Support

Topic locked