Log in or register to post comments

Meizu MX5 green pixel camera

July 6, 2016 - 4:48am #1

Vuforia SDK Version: 4.2.3 -

Description with steps to reproduce: Hello,

I created a simple android app using image target and ar camera. It worked fine in the game mode of UNITY. The problem came when I export it to my android devise. I got a green screen but the augmentation appeared when I pointed the device on the Image target.
https://drive.google.com/open?id=0B3UIX6sHzJA2MDZQUHY5aTZINWs

I have a Meizu mx5 mobile with an android version 5.0.1

How can I fix this problem? -

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: android 5.0.1 -

Mobile Device Manufacturer and Model name: Meizu mx5 -

Do the Vuforia Sample Applications show the same behavior?:

Meizu MX5 green pixel camera

August 5, 2016 - 2:56pm #6

Hello,

Sorry to hear of your struggles. The ARCamera implementation is the same in the Unity Extension as it is for the Unity samples. They are both derived from the same build artifact.

Thanks.

Meizu MX5 green pixel camera

August 5, 2016 - 7:09am #5

I tried all kind of combinations : 

I copied all the ARcamera settings in the ARCamera used in my project but I still have the same green screen. I exported the ARCamera from the sample project to my project and same I had the same green screen. 

 

The only way to make my phone camera work is to work in the sample vuforia project. 

 

Do you know what's the difference between the ARCamera in the vuforia sample and the one provided with the vuforia package?

 

Thanks.

Meizu MX5 green pixel camera

July 8, 2016 - 7:52am #4

Hello,

Sounds like there is a step missing in how you're executing the rendering function. I would suggest that you review the provided sample closely to insure that you're not missing anything.

Thanks.

Meizu MX5 green pixel camera

July 8, 2016 - 5:48am #3

Hello,

 

Yes it works with Imagetarge sample app of Vuforia. However, when I make a simple app with an ARcamera and ImageTarget, I get always the same problem. Should I change some parameters in the camera script or add autofocus features like in the SampleUI with the Vuforia sample app?

Meizu MX5 green pixel camera

July 6, 2016 - 8:35am #2

Hello,

Can the issue be reproduced using our sample apps?

Thanks.

Log in or register to post comments