Topic locked

testing app on android 10 api29 app doesn't install - api 28 and 30 work fine

Unity Editor
August 13, 2022 - 1:05am #1

Hello all,
Developing an app in Unity with vuforia latest version, and opening the apk file in Android Studio to test on the virtual devices with various android versions.
Tested multiple times with each device configuration, tried various virtual devices running android 10... doesn't install, error "missing matching ABI"
Tried changing to x86-64 android virtual machines.. still nothing.
Works fine on android 9 and 11 virtual devices and on my android 11 phone too !
I also tried installing app on android 10 phones and it didn't install.

Anyone have an insight as to why only this android version is causing the problem ?
Thanks in advance :)

Platform: 

testing app on android 10 api29 app doesn't install - api 28 and 30 work fine

September 8, 2022 - 4:16am #2

Hey there,

 

Sorry for the delay in response. Are you saying that you are testing your APKs via the Android Emulator? 

 

Kind regards,

Patrick Scheper

Vuforia Engine Product Manager

Topic locked