Log in or register to post comments

Car modelTarget still not recognized

March 20, 2018 - 4:55am #1


I have built a BMW car model,and then use model target to recognize.

but when i import it to the MTG,and get the dataset.

After imported in the unity project,i still donot know why the car can not be recognized.

Is there any way to solve this problem?


Or, does scanner tool work better than cad recognition?

here are the pic,which the project works in unity.

Image icon test.png1.64 MB

Car modelTarget still not recognized

March 23, 2018 - 9:57am #6


If you are using an unsupported eyewear device, it is expected that you will encounter issues. If you'd like to integrate your eyewear with our SDK, the first step would be to contact our sales team: https://developer.vuforia.com/contact-sales


Vuforia Support

Car modelTarget still not recognized

March 23, 2018 - 12:39am #5


are you still there?

I have another question that wanna ask.


I use digital eyewear ar glass to show the demo,and the camera captures lower image than we test it in unity editor.

can you tell me some suggestions to solve it?

The camera of the ar glass works fine,but we can not improve the quality of the camera image.

Car modelTarget still not recognized

March 21, 2018 - 6:58pm #4

Another story about this,we got not suggestions about the cad model from vuforia only if we made mistakes.

And we can just get more info from the internet.

we get this video from the internet.this link is https://youtu.be/OKbUXhEmi_M

the 2d guide line is quite simple ,maybe the shape of the car is so easy to track.

And whether you can give more suggestions about model target on the internet,maybe shows on the model target part of vuforia developer portal

Car modelTarget still not recognized

March 21, 2018 - 6:48pm #3

Thanks Strasza.

Another question,I am doing eyewear development using vuforia too.

we have a self-built AR glass,and we develop the app for the ar glass using vuforia.

But when we test it in the editor,we can get the camera image right.

But when we build the app to uwp,and we test the app on surface pro with our glass connected to it,the camera image has been scaled.

We wanna get higher definition picture from the camera of the ar glass,and our camera definition is 1280*720.


There are ways for me to solve,but i have tried.it does not work.

I have tried to get the webcamprofiles.txt to add my camera of ar glass involed and set the definition to 1280*720,

But After building the app ,the camera image seems to have no change,maybe the data of  webcamprofiles.txt has not been upgraded to the app.


I can show you the pictures below.

The well pic shows the situation that in editor it works.

the bad pic shows the situation that in app it works.

Image icon bad.png986.53 KB
Image icon well.png973.81 KB

Car modelTarget still not recognized

March 20, 2018 - 9:17am #2

Hello gaofei,

The screenshot you shared shows the guideview not completely aligning with your car, please align them exactly.

A few other tips:

It's recommended to remove transparent surfaces from the model imported into the MTG, such as the windows. These can cause issues as the MT feature may expect solid geometry there.

Reflections, such as the one seen on the front left of the car in your screenshot, will often cause issues with detection. Try to eliminate lighting that causes such reflections on your model.

Make sure your digital model accurately reflects the texturing of the physical model. The colors don't need to be the same, but the texture differences should be represented (i.e. the digital car shouldn't just be mono-color).


Vuforia Support

Log in or register to post comments