Log in or register to post comments

Error importing generated package

February 22, 2021 - 4:04am #1

Hi, I'm trying to create a demo for a client with Model Targets, and after generating a dataset from the Model Target Creator I've tried to import into Unity. 

In Unity it says it can't create the directory for the image preview and can't copy the XML file from the package.

I've tried opening the project both on 2019.4 and 2020.1, but the problem persists. The same with changing folders.

Does somebody know how to solve it?

 

AttachmentSize
Image icon vuforiaError.png24.46 KB

Error importing generated package

February 24, 2021 - 2:44am #6

Hi Aupuma,

I am glad that you where able to solve the issue.

Strange that you where able to use a glb file. We support folllwing extensions: 'pvz’, ‘gltf’ v2, ‘dae’, ‘fbx’, ‘igs’, ‘iges’, ‘obj’, ‘stp’, ‘step’, ‘stl’, ‘sla’, ‘wrl’, ‘vrml’.

Did you by any change use a convertor? glb -> gltf v2?

Could you please confirm the MTG version used?

Thank you.

Vuforia Engine Support

 

Error importing generated package

February 24, 2021 - 2:34am #5

Hi again,

1. I used 1 guide view

2. The model had no coloring

3.Windows version

4.I've tried recreating the target using a glb instead of an fbx and this time it works. The model now has colors and I made 3 guide views. Unity has not printed any erros.

Error importing generated package

February 23, 2021 - 1:04am #4

Hi Aupuma,

I've tested the with the setup you mentioned and I was *not* able to reproduce the issue. I created an untrained database.

Could you help me with the following:

1. Did you use GuideViews or trained database?

2. Did you encounter any errors when creating the database?

3. Which MTG did you use? for Windows or Mac?

4. Have you tried recreating the modeltarget?

5. Could you please provide us the folder with the model target database? Including x.vul,vup and dataset files?

Thank you.

Vuforia Engine Support

Error importing generated package

February 22, 2021 - 7:49am #3

Hi, the Model Target Generator is 9.7.4, downloaded directly from the website. The Vuforia Engine SDK is 9.7.5

Error importing generated package

February 22, 2021 - 6:52am #2

Hi,

Could you please confirm which Model Target Generator and Vuforia Engine SDK version are you using?

Thank you.

Vuforia Engine Support

Log in or register to post comments