Log in or register to post comments

Error Model Target Generator

March 5, 2019 - 1:35am #1

Hello. I tried several times to train a database in the Model Target Generator and it always works fine but since a few days it is not possible to train the database because of this error: Training failed: Model(s) arimfin01.viewpoint_front, arimfin01.viewpoint_right are broken, please try to re-export the models from your CAD tool and create new detection views.

I exported the OBJ again from Cinema 4D and imported it in TMG and did the whole process again (detection views etc) but it fails. The error is related to 2 of my 3 viewpoints.



Does anybody knows how to solve it. I appreciate your help. Thank you.

Error Model Target Generator

March 11, 2019 - 11:40am #5

Hello,

We see where you did another training with slightly altered settings. Unfortunately, it still led to a failure rate slightly above a 5% failure rate - the updated threshold is 5%.

As far as we can see, the distance-range for your training is set to go as close as 10 cm to an object which is 50 cm high. With this setting the training camera's position is inside the 3D object's bounding-box for many training views. Training renderings inside the 3D object's bounding-box can lead to failures.

Can you try with settings that are closer to the recommended defaults? This should help to reduce the camera's position being inside the 3D object's bounding-box, and reduce failures.

Thanks,

Vuforia Engine Support

Error Model Target Generator

March 9, 2019 - 4:32am #4

Hello. I tried it again and the problem is not solved. After waiting 20 minutes I received again the error: Training failed:

Model(s) arim03.viewpoint_right, arim03.viewpoint_front, arim03.viewpoint_leftare broken, please try to re-export the models from your CAD tool and create new detection views



Conclusion: the problem is not resolved.



Huibert (Samwork)

Error Model Target Generator

March 8, 2019 - 9:35am #3

Hello @samwork,

I was notified by the dev team that changes resulting from your failure have been pushed to production.

Can you attempt this training again to see if the issue is resolved?

Thanks,

Vuforia Engine Support

Error Model Target Generator

March 7, 2019 - 1:57pm #2

Hello,

Thanks for the report. I can confirm that the engineering team has identified an issue with the Model Target training system.

The summary of the issue is that there is a mechanism in the training system to terminate when detection ranges are are detected as being incorrect. This algorithm has been too agressive and the team will be deploying a fix in the next few days to change that.

I'll try to stay abreast of the resolution so that I can update the thread. Apologies for any inconvenience.

Thanks,

Vuforia Engine Support

Log in or register to post comments