Log in or register to post comments

Extended tracking enable even if Track Device Pose is disabled

July 10, 2018 - 5:52am #1

Since I update at Vuforia 7.2.20 version there is a big problem using HoloLens. Even if I haven't enabled the Track Pose, the program continue to use EXTENDED TRACKING. I can see this by using the function OnTrackableStateChanged. Furthemore the tracking is more unstable than before. How can I do to disable permanently EXTENDED TRACKING? Thanks

Extended tracking enable even if Track Device Pose is disabled

September 20, 2018 - 5:46am #5

After looking deeper into the API and the Vuforia initialisation process, you would probably want a script like that, which stops the extended tracking right after it gets initialised by Vuforia:

public class DisableExtendedTracking : MonoBehaviour
{
    PositionalDeviceTracker deviceTracker;

    void Awake()
    {
        VuforiaARController.Instance.RegisterVuforiaStartedCallback(OnVuforiaInitialized);
    }
    void OnVuforiaInitialized()
    {
        StartCoroutine(StopTracker());
    }

    private IEnumerator StopTracker()
    {
        deviceTracker = TrackerManager.Instance.GetTracker<PositionalDeviceTracker>();

        while (deviceTracker.IsActive == false)
            yield return new WaitForEndOfFrame();
        deviceTracker.Stop();
    }
}

 

Extended tracking enable even if Track Device Pose is disabled

September 18, 2018 - 6:34am #4

If that is the case, you could try to disable the ImageTargetBehaviour script, furthermore you can use a dummy object that interpolates over some position updates from the tracking to increase the accuracy.

Edit: You could also set a flag in DefaultTrackableEventHandler to manage the case where newStatus == TrackableBehaviour.Status.EXTENDED_TRACKED for each marker individually (you wouldn't gain a performance boost though)

Extended tracking enable even if Track Device Pose is disabled

August 31, 2018 - 10:44am #3

So any word on this or at the very least any idea how to access the camera in c# cause i cant seem to figure it out.  I just want the 3d model to align once then quite tracking.

Extended tracking enable even if Track Device Pose is disabled

July 30, 2018 - 5:54am #2

I dont know if this bug is already fixed or not, or hololens has more than one camera...

but you can use this bug to workaround this



"When switching to front camera, Model Targets extended tracking is disabled and will not re-enable when returning to back camera"

 

So I just switch to front camera and switch back to back camera to disable extended tracking... It works on iOS 11.3 where extended tracking actually messing around with object positioning

Log in or register to post comments