Log in or register to post comments

Failed to load data set in 7.2.23

August 14, 2018 - 1:39am #1

Hi

I wanted to test the model Target with AR-kit so I did the following

I am using;

Unity 2018.2.3f1

Vuforia 7.2.23

Model Target Generator 7-2-24

I created a new project, selected IOS as build target. Then enabled Vuforia and added an AR-cam.

I created a new development license and pasted it to the license field.

I chose TrackingMode POSITIONAL and Optimize for Model Targets and Ground Plane.

Made sure that the database was listed under the "Databases"

Added a new Model target, and my 3d object was selected and created.

Chose Guide View 2D.

When I hit play, vuforia immediately throws error "Failed to load data set xxx"

Is this a known bug? What have I done wrong?

I have checked the forum and made sure the app license was created brand new and all that but I can't even make a simple demo to work.

I can get the older versions to work, but I needed to evaluate the fusion abilities so I need to get the 7.2 vuforia to work.

Please help me!

Failed to load data set in 7.2.23

January 17, 2019 - 4:03pm #19

Hello,

Responding here as it looks to be a duplicate of this thread.

Thanks,

Vuforia Engine Support

Failed to load data set in 7.2.23

January 17, 2019 - 12:39pm #18

I tried also with unity 2018.2.19, vuforia 7.5.26.

it seems all dataset created with the new model target generator are corrupted, or something else..

I read some other posts talking about the .NET FP parsing problem, so I tried to reneame "." with "," in all XML.

nothing..

 

I'd like to try with the old target generator but it has been removed for the dev portal.

 

hope someone has a running solution.

 

thanks guys

 

Failed to load data set in 7.2.23

January 17, 2019 - 12:22pm #17

hi,

I have the same problem using unity 2018.3.0 or 2018.3.2, Vuforia 8 and the last model target generator.

I tried with an empty project and in another project with all core samples.

the Vuforia model target database loads without errors.

mine not.

I can see the Dataset in the inspector.

the license key is a developer one.

 

any idea?

 

Failed to load data set in 7.2.23

November 12, 2018 - 3:15pm #16

Hello,

It could also be possible that the dataset, as generated by the Model Target Generator, is not compatible with the version of the SDK you're using. As we've improved the Model Targets feature since launch, we've unfortunately have had to break backward compatibility.

What is your version of the MTG?

Thanks,

Vuforia Engine Support

Failed to load data set in 7.2.23

November 9, 2018 - 8:16am #15

Thanks for the tip. I believe I am already doing this; I've attached a screenshot of the page where I get my license key. Any other ideas as to why this could happen?

 

AttachmentSize
Image icon license2.png26.9 KB

Failed to load data set in 7.2.23

November 6, 2018 - 12:04pm #14

Hello @clach,

This is likely an issue with your Vuforia license. I suggest you replace the project's existing license with a free Developer license from the Vuforia Developer Portal.

Vuforia Classic and Cloud licenses do not enable the Model Targets feature.

Thanks,

Vuforia Engine Support

Failed to load data set in 7.2.23

November 2, 2018 - 9:08am #13

I'm getting a similar issue on the HoloLens. I am able to run the model target sample scene fine, but when I replace it with a model target I generated using MTG, I get an error "Failed to load data set X." This happens both with my own models and when I use the sample rover model to generate a model target. Is there an issue with the MTG?

Failed to load data set in 7.2.23

October 31, 2018 - 6:29pm #12

Update your Vuforia Version,I used version 7.0.2 and unity2017.4.f1 before, and this problem occurred.When I use unity2018.2.8f1 and Vuforia 7.5.26,solved this problem.

Failed to load data set "shoubing"

October 22, 2018 - 5:08am #11

unity 2017.3.1f1  vuforia 7.0.47

in unity  use Vuforia Model Target  error  Failed to load data set "shoubing"

model :  https://developer.vuforia.com/sites/default/files/dualshock-4-for-playstation-1.snapshot.75.zip

vuforia Model Target Generator unitypackage : https://developer.vuforia.com/sites/default/files/shoubing.unitypackage.zip

 

How to solve this problem?

Failed to load data set in 7.2.23

August 27, 2018 - 4:32am #10

IN CONSOLE

 

Failed to load data set in 7.2.23

August 17, 2018 - 11:35am #9

Hello,

ChoArrim wrote:

First of, I really need to thank you for your great support! Previously when I posted on this forum, the speed and quality of the support was not that great but it seems as if you maybe have increased the number of support personnel? In any case, I really appreciate this!

My pleasure. We are still resource limited but I am glad that we have been able to help in this case.

ChoArrim wrote:

I have tried your guide with the license error, and it didn't work.

Curious when you say "didn't work" is this for PlayMode? On device? Both?

ChoArrim wrote:

What did work was to NOT debug the app through xcode. Is this not supported by Vuforia or is this a bug?

Hard to say if this is a bug or not. You're stepping through your code with the Xcode debugger and the license check is failing in that case? It works if you just run it on device without the debugger?

ChoArrim wrote:

I am sorry but I am not allowed to give that either, especially now when we got it to work when setting a larger scale. Maybe would help if we got a warning in unity or model target generator that the object is too small?

We are looking at ways to provide better feedback to developers about the quality of their model target. Your current observations about getting is to work when setting to a larger scale are important.

What I don't understand are the steps you took to overcome/workaround the original issue reported: your Model Target device database would not load. Can you share more details here? I'm having a hard time understand where we have arrived in this dialogue.

Thanks,

Vuforia Engine Support

Failed to load data set in 7.2.23

August 16, 2018 - 11:11pm #8

Hi @medabit

First of, I really need to thank you for your great support! Previously when I posted on this forum, the speed and quality of the support was not that great but it seems as if you maybe have increased the number of support personnel? In any case, I really appreciate this!

I have tried your guide with the license error, and it didn't work.

What did work was to NOT debug the app through xcode. Is this not supported by Vuforia or is this a bug?

 

I am sorry but I am not allowed to give that either, especially now when we got it to work when setting a larger scale. Maybe would help if we got a warning in unity or model target generator that the object is too small?

Failed to load data set in 7.2.23

August 16, 2018 - 2:59pm #7

Hello @ChoArrim,

I did some additional testing with your license key (I have access to it using portal admin role) in an app today and could not replicate your error.

This means that there is something wrong with either the license key as embedded in your app, or the license check protocol. Please try the following:

  1. Completely uninstall and reinstall your app. Before running the app, turn Wifi off (this will block the license check service, and validate that the Vuforia license key string is valid. The clean install will also remove any residual Vuforia cached data). Run the app and see if the database failed to load.
  2. Exit the app
  3. Re-enable Wifi and again run the app. See if the database failed to load. If this is the case, it is likely due to a license check failure

If #3 fails to load the database, then we're back to where we started: license check fails for you, succeeds for me.

My final theory is that somewhere in the network connection to our license check service, something is intercepting our HTTP request and providing a non-valid response. We've seen failures like this due to website blocking software. The blocking software response (usually a web page saying you cannot access the site) is received by the SDK, which logs it as a failure. This would fail the license check.

We've investigated this by running doing steps 1, 2 and 3 on home networks where there is no blocking software.

Lastly, I checked with our operations team and they were able to find multiple instances of this license hitting our server and returning license check passed.

Thanks,

Vuforia Engine Support

 

Failed to load data set in 7.2.23

August 16, 2018 - 12:26pm #6

Hello @ChoArrim,

I understand that you cannot share the 3D model .

Would you be willing to share the Model Target Generator project file (Fixturlaser2.vup) that was used to create the dataset? This would be helpful, as well.

Thanks,

Vuforia Engine Support

Failed to load data set in 7.2.23

August 16, 2018 - 4:25am #5

Hi @medabit

I am sorry, but I am not allowed to send those 3d models.

In any case, I tried to remake the model target with a bigger scale and now I can get it to work with Unity editor, but when I try and build it to my iphone I get these errors in Xcode:

FixturLaserTest2[9384:7139368] ERROR/AR(9384) 2018-08-17 13:17:23: Dataset Vuforia/Fixturlaser6.dat not valid with the used Vuforia license. Please check your license.

2018-08-16 13:17:23.003868+0200 FixturLaserTest2[9384:7139368] ERROR/AR(9384) 2018-08-17 13:17:23: Dataset Vuforia/Fixturlaser6.dat not loaded successfully.

Failed to load data set Fixturlaser6.

 

Is a free developer license no longer valid for trying the app on the iphone? I created the license Aug 14, 2018 10:20.

Failed to load data set in 7.2.23

August 15, 2018 - 2:02pm #4

Hello @ChoArrim,

I was able to replicate the issue with the database you provided.

Can you provide the 3D model that you imported into the Model Target Generator? This would be the next artifact required to isolate the issue. If you're not comfortable sharing it here, please DM me a link to download it.

Thanks,

Vuforia Engine Support

Failed to load data set in 7.2.23

August 14, 2018 - 9:52pm #3

This is very strange. The Default model target is in fact working.

Is there something that has gone wrong with my model target?? I created the model target according to the tutorials.

I included my created model target in this post so maybe you can try it yourself and see if there is something that went wrong all the times we tried to create it (we created it 3 times to make sure this wasn't the case)

AttachmentSize
Package icon Fixturlaser2.unitypackage.zip775.13 KB

Failed to load data set in 7.2.23

August 14, 2018 - 9:22am #2

Hello,

I don't see any reason why the dataset would fail to load with your workflow. I would suggest that you use our sample app to validate the dataset loading issue. This should be as simple as entering your development key, importing the dataset you created, and then selecting it in the prefab (replacing the Mars lander).

Let me know how that goes.

Thanks,

Vuforia Engine Support

Log in or register to post comments