Log in or register to post comments

Failed to load dataset in 8.0.10

January 17, 2019 - 12:42pm #1

hi,

I have this problem using unity 2018.3.0 or 2018.3.2, Vuforia 8.0.10 and the last model target generator.

I tried with an empty project and in another project with all core samples.

the Vuforia model target database loads without errors.

mine not.

I can see the Dataset in the inspector.

the license key is a developer one.

 

I tried also with unity 2018.2.19, vuforia 7.5.26.

it seems all dataset created with the new model target generator are corrupted, or something else..

I read some other posts talking about the .NET FP parsing problem, so I tried to reneame "." with "," in all XML.

nothing..



I'd like to try with the old target generator but it has been removed for the dev portal.

only vuforia samples are working.





hope someone can provide a running solution.



thanks guys

Failed to load dataset in 8.0.10

February 15, 2019 - 3:05am #6

Hello There,

- Upgraded to Vuforia Engine SDK 8.0

- Using Unity 2018.2.14f1

It worked fine.

Thanks guys.

Failed to load dataset in 8.0.10

February 14, 2019 - 9:32am #5

Hello @Samih,

Which version of Vuforia are you using? Unity Editor->Window->Vuforia Configuration

It is highly recommended to use the 8.0 Model Target Generator with the Vuforia Engine SDK 8.0.

Thanks,

Vuforia Engine Support

Failed to load dataset in 8.0.10

February 14, 2019 - 7:20am #4

Hello,

I am still not able to get this right.

- Using Unity 2017.4.10f1

- Using the last Model Target Generator (MTG) to generate a database for a CAD file.

- successfully imported the generated unitypackage into my Unity project.

- Created a development key.

Failed to load dataset on HoloLens

 

And advice?

Thanks guys.

Failed to load dataset in 8.0.10

January 20, 2019 - 12:55pm #3

hi,

I found the problem.

I was using an old development key. the same I use for demos.

that key doesn't support model tracking.

using a new key is the solution. now everything works!

 

thanks 

Failed to load dataset in 8.0.10

January 18, 2019 - 9:34am #2

Hello,

Sorry but I'm a bit confused by your post as there is a lot of information. Let me see if I can summarize the salient points:

  1.     You had a working device database generated by "previous version" of the Model Target Generator (7.5.X)?
  2.     The device database from #1 was working with SDK 7.5.X, Unity 2018.2/3, in that it could load?
  3.     You took the 3D model used to create the device database in #1 and loaded it into the most recent version of the Model Target Generator (8.0.10)?
  4.     The device database created in #3 does not successfully load with SDK 8.0.X?

Please correct or confirm anything above. The Model Target Generator release notes state "Model Targets generated with previous versions of the Model Target Generator (MTG) remain compatible with Vuforia Engine 8.0 as single Model Targets." so there is an expectation for compatibility, but obviously there are always exceptions.

Ultimately, the best way for us to debug this is to have access to the 3D model you're having issues with so that we can use it for an RCA.

Thanks,

Vuforia Engine Support

Log in or register to post comments