Log in or register to post comments

HoloLens: Model Targets won`t work - tested with various Unity and Vuforia SDK versions

July 25, 2018 - 4:43am #1

Hello,

I am somehow not able to get the tracking done on Model Targets through the HoloLens. On an external Webcam the tracking does work flawlessly. I have followed the standard Hololens Build and Player Settings with all the recommended Options (checked VR/Vuforia, License Key, Database checked, Digital Eyewear, HoloLens, etc.). The Target Model from the Target Generator has the correct real life dimensions as well.

When it gets deployed on the HL through VS or the Remote Connection through Player in Unity, it mostly shows a black scene (even though I use skybox instead of solid color). On the 2017 Unity Versions I can see the 2D Guide View, but on this point I am not able to track the object through the HoloLens Remote Session and the debugger doesn’t give me a match output. Sometimes it sporadically matches the model with the window or other forms in the room. Somehow on an external Webcam the tracking works without any issue.



Following Setups were used:

    HoloLens 10.0.17134.165

    HoloToolkit-Unity-2017.2.1.4 / HoloToolkit-Unity-2017.4.0.0

    Unity 2017.3.0f3 - Vuforia 7.0.50

    Unity 2017.4.7f1 – Vuforia 7.0.57 / 7.2.20

    Unity 2018.2.0f2 – Vuforia 7.2.20 / 7.2.23

I would appreciate if someone could provide solution or how-to for getting the SDK to track Model Targets through the HoloLens. I have searched up the Forum, stackoverflow, Tutorials, Youtube but I can’t get the problem solved.



many thanks in advance

Peter

Log in or register to post comments