Log in or register to post comments

Issue with physical length showed in Unity

December 18, 2018 - 5:59am #1

My model targets have an enormous physical length compared to what MTG is showing and what they are in reality. I have tried with .OBJ and .FBX, different sizes before creating the target. I also tried changing the units in the MTG between m, cm and mm while facing the same problem. If i bring the sizes in unity down it also scales down the model target making it impossible to see. 

Unity version: 2018.3.0f1

Vuforia: 7.5.26

Model Target Generator: 7.5.20

 

AttachmentSize
Image icon MTG length.PNG15.4 KB
Image icon Physical length.PNG28.33 KB

Issue with physical length showed in Unity

December 21, 2018 - 1:22am #3

I have already found what the problem was. It had to do with the unity version 2018.3. As soon as i imported a new model target, the proyect was bugged and the model targets were showing in the inspector lengths out of porpotion (over 600000 meters) when they should be like 0.6 meters. I downgraded to 2018.2 and i still had the same problem with my proyect imported from 2018.3 but when i tried 2018.2 with the vuforia sample test on a NEW proyect there was no more bugs. Knowing that i decided to create a new proyect and import my proyect into the freshly new one and the bug dissapeared from my proyect.

Issue with physical length showed in Unity

December 20, 2018 - 1:59pm #2

Hello,

To clarify, the issue you're having is that the values displayed in the MTG are not what is represented in the inspector?

If correct, can you please provide either or both of the following:

  • The 3D model you're importing into the MTG and causes a problem
  • The resulting .vup and .vul files (as generated by the MTG) when creating the problematic device database

If you don't want to share these publicly, please DM me a link.

Thanks,

Vuforia Engine Support

Log in or register to post comments