Log in or register to post comments

Model Target fails in Unity

November 5, 2019 - 9:18am #1

I am building an AR app in Unity using Model Targets. Essentially, I want to scan the sign on a building and have an animated model augment over the top.

I am having a couple of issues and they seem to be related to the Unity part of the process.

I have built the model target in the Model Target Generator (8.5.8) and tested it successfully in the Model Target Test app, so I know the target itself is working.

Once I import it into Unity(2019.2.9f1, Vuforia Engine 8.5.9), however, I start to have problems.

1: the target imports at 10x real world scale

2: I do not see the guide view in play mode (I have tried all the different options for this)

3: When the animated model (.fbx) is placed in the scene and attached to the model target, the camera preview shows it but it does not display in play mode. (If it is in the root, it displays fine the problem is only when it is placed under the model target). If I turn on the bounding box, this displays, but no model.

4: when I have a webcam attached I receive a "failed to load dataset" error. I do not receive this when I do not have a webcam attached.

I know this is a lot, but I have spent the last several weeks searching for answers and none that I have found seem to work.

Unity 2019.2.9f1, Vuforia 8.5.9, MTG 8.5.8

Thanks in advance.

Model Target fails in Unity

November 12, 2019 - 12:24am #2


Just checking in to confirm that the issue is the same as in https://developer.vuforia.com/forum/model-targets/model-target-problems and has been solved by the license?

Thank you.

Vuforia Engine Support

Log in or register to post comments