Log in or register to post comments

Model Target Tracking works on Android and Editor but not in iOS

March 21, 2018 - 2:39pm #1

Hi Vuforia Team, 

 

we have an really annoying problem. We tried the model target tracking now with different model targets. All of them worked perfectly on Android (Pixel 2) and not bad in the Unity Editor (Platform iOS and Android). But it will not work on iOS (Testet with iPhone 7 and iPad Pro 10.5). We tried it with nearly all Unity Version which should work with model targets (2017.3.0;2017.3.1; and different patched versions of them and different Unity 2018 beta version) Everything looks good. Dataset is loaded die guide view is also the right one. On time it tracked one of the model target really good on iOS (for a long time -> did not looked like a false positive) but before that we rotate the iPhone 7 several times and suddenly it worked perfect. After that it never worked again. We get just one related errors (error is:

CameraDevice::getCameraCalibration(): Failed to get camera calibration because the camera is not initialized.)

and it even logs in xCode that the right model target is loaded and activated (no other targets inside). We even tried the native version of your SDK for iOS and we have the same problem there.

 

So this is really annoying cause we think we should have done everything right (same project works perfectly in Android and Editor). We also tried different model targets. So can you maybe help us with our problem? There must be one special setting we forgot for iOS or something similar cause it works on Android. Is there maybe a version of your SDK which you can recommend working with iOS and Model Targets?

 

Thanks for your help.  

Model Target Tracking works on Android and Editor but not in iOS

July 18, 2019 - 4:36am #7

Any news here? 

Model Target Tracking works on Android and Editor but not in iOS

April 6, 2019 - 9:53pm #6

I’m wondering if it has to do with iOS 12.2 which is the worst update, broke many many things.

I posed an issue earlier: https://developer.vuforia.com/forum/unity/vuforia-errorar-cannot-setmode-ar-camera-init-videobackgroundconfig-screen-size-zero-received

My phone updated recently automatically and now Vuforia’s background video doesn’t work: https://developer.vuforia.com/forum/unity/vuforia-errorar-cannot-setmode-ar-camera-init-videobackgroundconfig-screen-size-zero-received

Model Target Tracking works on Android and Editor but not in iOS

March 28, 2019 - 5:51am #5

Hi I have the exact same issue as the original poster.

 

I've just tested 5 different Model Targets (in separate unity scenes) and these are the results:

 

Unity Editor Windows 2019.3.10: tracking works perfectly.

Unity Editor MacOS 2019.3.10: tracking is unusable and the model target gets continuously stuck in random places.

Android (Google Pixel 3): tracking works perfectly.

iOS (iPad 6th Gen - the editor includes a vuforia version that's listed as compatible with this iPad): tracking is unusable and the model target gets continuously stuck in random places.

 

Model Target Generator ModelTargetGenerator-8-0-10

iOS 12.2

Unity 2018.3.10 (includes vuforia 8.0.1.0)

Model Target Tracking works on Android and Editor but not in iOS

August 8, 2018 - 12:39pm #4

Hello,

lacouture100 wrote:

Hey, any chance you could fix this. I have the exact same problem!

Unfortunately, I never heard back from the other developer reporting this issue. There is no special setting in the SDK to enable Model Targets on iOS.

If you're interested in pursuing, please provide the same information I previously requested:

  • Model Target Generator version used
  • Unity Version used
  • iPhone 7 iOS version
  • 3D model imported into the Model Target Generator (please DM me a link)

Thanks,

Vuforia Engine Support

Model Target Tracking works on Android and Editor but not in iOS

August 8, 2018 - 11:51am #3

Hey, any chance you could fix this. I have the exact same problem!

Model Target Tracking works on Android and Editor but not in iOS

March 22, 2018 - 7:58am #2

Hello,

Can you provide the 3D model that is being used, and does not detect on the iOS device? If you do not feel comfortable posting it to the forums, then please DM a link to my account @medabit.

Additionally, the following information would be helpful:

  • Model Target Generator version used
  • Unity Version used
  • iPhone 7 iOS version

I'd like to attempt to replicate your observations by going through the entire Model Targets workflow, using your 3D model and the latest commercial versions of the SDK and tools.

Thanks,

Vuforia Support

Log in or register to post comments