Log in or register to post comments

Model Targets Generator and Test App

January 25, 2018 - 6:52am #1

We've been experimenting with the new Vuforia Model Target Generator and the Model Target Test App.

What we've done:

- Importing an FBX with textures into the the generator is no problem.

- Setting the correct dimensions (units) and up is no problem.

- Creating a Detection Position is working, and shows an nice outline.

- Installed the APK of the test app on our device (samsung S7)

- Tested the App with the pre-installed lunar lander with 2 images (from the website, no 3d print) both work fine, stable and fast.

- Uploaded the created files on my Samsung S7 and they are found by the app.

- Selected the files and i see the outline appear.



But then nothing happens, No recognition, no feedback, nothing in Android Studio, nothing on the screen.

What's happening here? is it not registering? Is my file incorrect? why isn't it working? Any kind of feedback would be appreciated.

So we tried something else:

- Installed the newest version of Unity (2017.3.0f3)

- Installed the Vuforia plugin, and enabled it from the XR menu in unity.

- Imported the generated package from the Model Target Generator.

- Ran the scene with webcam attached (in directX11).

- Shows the 2d outline

- Nothing happens, no feedback, warning or errors.

So it could be the 3d model.

So we tried another 3d model (which the old 3d model scanner really loved, nice textures and color changes is what vuforia really likes).

Again, nothing.

What is happening here? Where is the bug? Is the generator broken?

 

Model Targets Generator and Test App

February 21, 2018 - 1:27am #12

So, We've found out whats wrong with the software!

Everythings working now, as long as we don't change the units settings.

This will give a strange tracking in the test file, but you can easily change it in Unity itself.

So it works... not yet with the papercraft airplane, don't know why it's not working.

But we have several cars working. Which is nice.

Regards,

Rens

Model Targets Generator and Test App

February 13, 2018 - 11:13am #11

Are you testing this against an image of the car or the actual car?

In terms of the original models you posted, here's some additional feedback from the team.

The current Model Target feature is not designed to work with realistic-looking textures with many different colors. They work best with single-colored surfaces that contain logos, etc. For this instance, try your models without the textures and see if it performs better. These targets have a lot of geometry so it should be possible to detect without accounting for the texturing.

Thanks,

Vuforia Support

Model Targets Generator and Test App

February 9, 2018 - 1:54am #10

We have a befriend company who has it working.

They Created a simpel car demo.

We've received their Car model FBX, which they used. And i've received their data files.

When I Upload their datafile to my S7, it works!

When i use their file, build it with almost exactly the same screenshot and outline, and upload it to my phone, it doesn't work.

The Data files are exactly the same. The Vuforia Model Target Generator is the same version (7.0.47).

 

Model Targets Generator and Test App

February 4, 2018 - 11:13pm #9

@Strasza @VuforiaSupport

Scale is set accurately, all is in CM's and in the generator tool the giving size is correct with the physical size.

We tried several different views, For the plane we tried about 7 views. The last one was a top view, so i've made a screenshot of that. But we tried all sides and different angles. 

For the house model. The waterwheel doesn't move, it's locked into place. We wanted to create a stream in AR. But that won't happen anytime soon.

So There is no reason why it shouldn't work. So please tell me why that model won't work.

I Really think your software is broken. I Suspect it might be a small, since it does work with the provided 3d model of the lander.

This isn't the only post with this issue.

 

Model Targets Generator and Test App

February 2, 2018 - 8:58am #8

Hello fantazmRL,

In the screenshots you've provided it doesn't look like the guideview will necessarily match the object. Is your scale set accurately? Have you tried other guideviews here?

For the house model, the water wheel you included in the model is not necessarily a good thing to include in the model if it moves as the position won't be the same every time you try and detect it.

For the jet, a guideview from above or one of the sides isn't the best idea because it'll only see the geometry of a single side of the object. I'd recommend having the guideview looking at the target from a slight angle.

Thanks,

Vuforia Support

Model Targets Generator and Test App

January 31, 2018 - 6:56am #7

What is happening here?

Got really annoyed (once again). Did try something new.

Took the .pvz model from the moonlander.

Imported it into the Generator tool. Took a different point of view (side).

Made a build and imported it into Unity.

And it worked! Even from my screen... It worked... why does that work?

Why don't my own models work?

Whats happening here?

Model Targets Generator and Test App

January 31, 2018 - 3:05am #6

@Jari, Thanks for the reply, we did set it active. See the attached screenshot.

@Loczis, I don't understand the question. What do you mean with the base?

@plfamant, Yes we did use Unity Editor, Build the App and used the TestApp

AttachmentSize
Image icon UnityScreenshot.PNG399.08 KB
Image icon ARCamera.PNG70.83 KB

Model Targets Generator and Test App

January 29, 2018 - 4:50am #5

Have you activated the new model target dataset and deactivated the standard one? There can only be one model target dataset active at the time.

ARCamera > Open Configuration

 

Model Targets Generator and Test App

January 29, 2018 - 3:20am #4

did you try to set your base on an active ARCamera?

Model Targets Generator and Test App

January 29, 2018 - 1:36am #3

Did you test in the Unity Editor?

 

Pierre

Model Targets Generator and Test App

January 29, 2018 - 12:33am #2

Some feedback would be appreciated!

Log in or register to post comments