Log in or register to post comments

Not showing other GuideView than the first one

January 25, 2019 - 12:29am #1

Hello,

I am on Unity 2018.2.18 with Vuforia 8.0.10 (tested on Editor and Android) and an Editor key.

 

I imported the classic VuforiaMars_ModelTarget (or a database that contains only one model I created with the ModelTargetGenerator, only one database at a time).

When I choose "GuideView2D" and the Front image for the Mars Model Target, it appears; but when I choose the Rear GuideView, it doesn't show on screen.

The same thing happen with my ModelTargets. If a ModelTarget has more than 1 GuideView, only the first appears.

 

Did anyone experience the same thing ?

 

Thank you

Not showing other GuideView than the first one

January 28, 2019 - 2:24pm #7

Hello,

We are investigating an issue where not all Model Target guide views are not being shown in PlayMode, nor when deployed to device.

I'll update this thread with any relevant details.

Thanks,

Vuforia Engine Support

Not showing other GuideView than the first one

January 26, 2019 - 10:45am #6

Hello,

I face this issue with every databases generated by the ModelTargetGenerator ( I have the version 8.0.10)

For any unity package I generate with the ModelTargetGenerator, there are previews images (the one that appear in UnityEditor when I chose a guideview) but no outlook (the one that appear at runtime)

PS : I am not interested in recreating the VuforiaMars ModelTarget database, as I do not have a real model of it, and I have restricted number of ModelTarget I can export from the ModelTargetGenerator 5 I try to contact vuforia for VIP and buying a PRO licencen but no answer from them on that. I will create a post specifically for that)

 

 

Not showing other GuideView than the first one

January 25, 2019 - 12:56pm #5

Hello,

Looks like there is an issue with the VuforiaMars_ModelTarget device database as packaged with the current Vuforia Samples. After some additional investigation we found that the "front" preview image is missing in the /Editor/Vuforia/VuforiaMars_ModelTarget folder.

If you want to use the Mars lander as an example 3D model, then you can take the following steps to recreate it with both guide views:

  1. Open 8.0.10 version of the Model Target Generator
  2. Import the packaged Vuforia model: \Model_Target_Generator-win32-x64\resources\sampledata\VuforiaMars_ModelTarget\VuforiaMars_ModelTarget.pvz
  3. Orient the 3D model
  4. Select "Detection Position"
  5. Select "Add Multiple Views->2 Views"
  6. Resize the guide views (optional, as needed)
  7. Label the views accordingly (optional)
  8. Select "Create Target"

Import the resulting .unitypackage into your project. You should see both guide views in the ModelTarget inspector, PlayMode (click on the Mars lander icon to toggle), and when deployed to device.

Thanks,

Vuforia Engine Support

Not showing other GuideView than the first one

January 25, 2019 - 11:23am #4

Hello,

Thanks for the clarification. Actually, the confusion was on my part as I was looking at the wrong device database.

I need to do some research here to better understand the issue. Will get back when I find something out.

Thanks,

Vuforia Engine Support

Not showing other GuideView than the first one

January 25, 2019 - 10:31am #3

I am sorry for the confusion.

The Rear GuideView is a guideview of the VuforiaMars_ModelTarget named Rear (there are 2 guideview for this model one named Front and one named Rear).

This issue has been observed in Unity Editor and when running the app :

- I create a Vuforia/ModelTarget (if there is no ModelTarget avalaible, Unity suggest me to import VuforiaMars database, I agreed)

- In the new ModelTarget created, I inspect the ModelTargetBehavior and select 2D GuideView in front of the GuideView Mode parameter.

- Another parameter named "Guide View" shows up, where I can select any guideview present in the ModelTarget (in VuforiaMArs : Front and Rear, in my models they finish with 0000or 0001 because I do not rename them in the ModelTargetGenerator)

The issue is : if I select the first GuideView in this list, the GuideView appears when running the app (or in the Editor); but if I select any other GuideView, the GuideView doesn't appears on screen.

Not showing other GuideView than the first one

January 25, 2019 - 9:38am #2

Hello,

Apologies, but I'm not familiar with the "Rear GuideView". Can you explain how you find this option?

Additionally, is the issue with observing the guideview in the Unity Editor? Or after the app has been deployed to device?

Thanks,

Vuforia Engine Support

Log in or register to post comments