Log in or register to post comments

Problem with depth mask occluding

November 26, 2019 - 9:12am #1

Hello and thank you in advance for reading through my problem!

I am working on an educational app with vuforia, in which i want to show name tags of the different parts of the human skull next to a 3D printed one.

For this purpose, i created a Model target with the 3D Model of the skull. It works fine and gets tracked quite well.

Then i placed the same 3D model in Unity over the model target and applied a Occluder material that uses Vuforias Depth mask shader, so the name tags behind the skull are not visible.

I changed the "ZTest Always" in the shader, since i learned that this gets rid of the black pixel things.

Sttill, the result is not good:

Top perspectiveTags from the back lurking through

 

It seems that the tags are only shining through when they sit inside the two walls of the skull, front and back one, as if the problem appears when  the occluding mesh is overlapping? If you look at one of the top tags, where no other mesh is behind, the lines and the sphere get occluded how expected....

I also tried a custom depth mask shader i found on a forum, but the result is the same...

I tried replacing the 3D Model in unity with a different one, thinking that it might be a problem with the mesh, but nothing changed..

Has anyone seen this before or has an idea what to do? thanks in advance!

I hope it is understandable, if you need more info, i'm happy to answer quickly.

Problem with depth mask occluding

December 4, 2019 - 4:12am #3

@mcotora

Hi!

I already changed it to OpenGLES2 and deleted the other alternatives in the list, but it didn't solve the problem :/

Now i tried to work around the issue, detecting the points that are visible to the camera via Raycast and only showing those, but the labels are flickering (maybe because the camera jitters so much? I haven't found a fix for that yet..)

 

 

 

 

Problem with depth mask occluding

December 2, 2019 - 5:10am #2

Hi,

Could you please also change the Graphics API to only GLES2? and let me know if this solved your issue?

Thank you.

Vuforia Engine Support

Log in or register to post comments