Log in or register to post comments

Some problems with make app using Model Target

December 22, 2017 - 7:35am #1

I'm a newbie at Unity and AR development, I want to try the Model Generator, but I was confronted with the fact that my object was not recognized. What I have done:

I created a new Unity project, generated target with Vuforia model target generator, imported the received .unitypackage into the project. Removed the standard camera, added the components: ARcamera and Model Target. Got the application key, configured Vuforia, turned on the database. Added a few primitive 3d objects to render when the target will be recognized. But it not works for me. Have I made something wrong, or there are some problems with the object which I use for recognizing?

Is it normal that in the Unity scene, the target model has no textures?

Does the location of the camera in the scene matter for AR apps?

I used the 2 cardboard boxes, one stands on the other.

The target was generated successfully.

No any bad messages in the Unity Console

Thanks in advance for replies.

AttachmentSize
Image icon Снимок.PNG169.8 KB
Image icon UnityScreenshot.PNG441.13 KB
Image icon photo_2017-12-22_18-28-41.jpg175.93 KB

Some problems with make app using Model Target

December 22, 2017 - 10:09am #2

Hello ngrypie,

Your workflow sounds correct, but your object looks too simple for the Model Targets feature. As mentioned here: https://library.vuforia.com/articles/Solution/model-targets-user-guide.html

"Geometric complexity is useful to distinguish an object from other shapes in the environment. Simple shapes such as cuboids, or very elongated simple shapes may be easily confused with other objects in the user’s setting."

You can try setting your guide view and making sure you are looking at your object from the correct angle, but this object likely doesn't have sufficient geometry for the Model Target feature.

Thanks,

Vuforia Support

Log in or register to post comments