Log in or register to post comments

NEED HELP: "Could not find specified video device"

August 8, 2016 - 12:40pm #1

Vuforia SDK Version: 5.5.9 -

Description with steps to reproduce: Hello Everyone!

I've scoured the web for an answer to this ERROR message:
"ERROR - Could not find specified video device
UnityEngine.WebCamTexture:Play()
Vuforia.WebCamTexAdaptorImpl:Play()
Vuforia.WebCamImpl:StartCamera()
Vuforia.CameraDeviceImpl:StartCameraDevice()
Vuforia.CameraDeviceImpl:Start()
Vuforia.VuforiaAbstractBehaviour:StartVuforia(Boolean, Boolean)
Vuforia.VuforiaAbstractBehaviour:Start()"

It seems like a lot of people have come close to the solution but it appears to be a bug.

WHAT I AM TRYING TO DO:
Use my iPhone 5 with the Kinoni Software: EpocCam to stream my iPhone Camera and use it as a WebCam for Unity + Vuforia.

SOFTWARE:
EpocCam
Unity 5.4.0f3 (32-bit)
Vuforia 5.5.9
.NET Framework 4.6.01038
MSV C# 2015

WHAT I'VE TRIED:
I've attached the phone to the PC. It reads as connected.
In Unity + Vuforia my Laptop Camera works but it's rubbish!
In the Inspector for the "ARCamera", under "Web Cam Behaviour (script)", I can select the "EpocCam" and it seems to accept that fine.
Following the forums it seems I have to add "EpocCam" to the device list in the "profiles.xml" located in Assets/Vuforia/Editor/WebCamProfiles (https://ibin.co/2qtLfFCzhgsp.png)

I put in the iphone's camera dim's, which is 1080p, in the size of the web cam texture and hit save.
Unity auto refreshes and the error shows in the console, black preview, nothing... (https://ibin.co/2qtM2f1SNFRw.png)

Can someone help an AR Dev noob?
OR if it's a bug, as plenty of forums have said... FIX IT VUFORIA!!!

Thank you for taking the time to read ^_^
Jake

-

Development OS (Mac OS X, Windows, Linux): Windows 10 Personal 64Bit -

Mobile OS and Version: 9.3.3 -

Mobile Device Manufacturer and Model name: NE434B/A -

Do the Vuforia Sample Applications show the same behavior?:

NEED HELP: "Could not find specified video device"

October 16, 2019 - 7:52pm #5

I know this thread is a little old but I ran into the same issue - if you run into this go into Windows Settings/Privacy/Camera and set "Allow apps to access your camera" to "on." - that fixed it for me.

NEED HELP: "Could not find specified video device"

August 5, 2018 - 8:44am #4

I also have the same problem on:

- Windows 10.0.17134

- Unity 2017.4.1f1 (64 bit)

- Vuforia 1.0.50

I can't get Unity to play and preview my app using my laptop webcam (or any other USB webcam), although I can build Android apps and they work fine (the only problem is the amount of time it takes me to do every single test on my phone).

Has anyone been able to solve this?

NEED HELP: "Could not find specified video device"

February 16, 2017 - 4:00am #3

Did you Solve the this  problem ? I have met the same problem when i use EpocCam and vuforia .

NEED HELP: "Could not find specified video device"

August 19, 2016 - 3:09pm #2

My stupid decision

I had this problem

I uncheck DefaultInitializationErrorHandler script in Inspector - my app is works and then i check this scipt and app works again.

Try it

 

Log in or register to post comments