Log in or register to post comments

Multiple Object Target detection

November 30, 2016 - 10:48pm #1

Hello. I am some what new to Vuforia and Unity. I am stuck at a problem where I have two object targets ( say, a car and a surfer) in a scene. I didn't do any sort of augmentation right now on them. Just want to them to be detected. When I play the scene, using my webcam, the object target which first gets detected (say car), is detected the rest of the time. The other one (surfer) doesn't get detected, at all. Same goes the other way round. However, when I keep both of the objects together closely, and point my webcam at them, both of them gets detected, and now if I separate them (with the scene running), and use the webcam to point to each of them separately, each one gets detected.

So the problem is, what I understand is, The first detection, which ever it is, one of them, or both of them together, is deciding what to be detected the whole time when the scene is in play. But this is not correct, right? If I have two objects in my scene, each of them should be detected independently of the other. I even tried with "Max Simultaneous Tracked Objects" value to 2 (even though I guess it has nothing to do with the problem I mentioned), nothing changes.

Please help me out guys, I am kind of on a tight schedule. Thank you very much, in advance. 

Multiple Object Target detection

December 21, 2016 - 5:48am #6

Thanks a lot for the resolve. I checked it and it's working!!! Can you give some ideas about my second issue which I mentioned in this thread?

Multiple Object Target detection

December 20, 2016 - 4:44pm #5

Hello,

The original reported issue has been fixed as part of Vuforia 6.2. There should be no need to regenerate your datasets, only upgrade your project to the 6.2 release artifact.

Thanks


Multiple Object Target detection

December 4, 2016 - 9:37am #4

One more thing I wanted to ask. If I have a scene and it contains more than one target, when I customize the default event handler script for one of the target, it changes for the other targets as well. I didn't do any "apply" on the target prefab (so the particular instance of the prefab for which I am changing the script should only change, not the whole prefab, and therefore other targets' default event handler script ). Why is this happening?

Multiple Object Target detection

December 3, 2016 - 12:46pm #3

Hello priyamdey and medabit,

I can confirm priyamdey's report about this bug. Its seems that the issue lies within the VuforiaBehaviour script attached within the ARCamera prefab.

If you point your camera at the first target and it tracks and then move over to the second target (which it will not), restart the VuforiaBehaviour script (promptly turn off and turn off the script), the second one now tracks, and so will the first. 

 

I have tried looking into that issue and my work is currently blocked since that script inherits from a dll which I am not familiar with.

 

Please have this bug fixed soon and please do update a solution over this thread to keep us updated.

 

I appreciate your help and look forward to your reply soon.

 

Thank you.

Multiple Object Target detection

December 1, 2016 - 5:05pm #2

Hello,

We are actively investigating this issue. I will provide an update once I have more information available.

Thanks


Log in or register to post comments