Log in or register to post comments

No target detection at 5 star rating

November 23, 2018 - 3:24am #1

Hi, I'm currently losing my mind over this. I have a database that contains 80 targets that all work fine (fast detection, stable tracking). They all have between 3 and 5 stars. Now, there's one target that has 5 stars but almost never gets detected on older devices (iPhone 5 for example), even though everything seems as though it should work. It got detected maybe twice out of 20 tests.



I've attached an image of the feature points. Since it's almost impossible to change the design at this stage, I would like to know if there are any other tips & tricks I could use to solve this problem. Any information would be helpful!







 

AttachmentSize
Image icon vliegendhert_v5.png57.21 KB

No target detection at 5 star rating

November 27, 2018 - 10:35am #2

Hello,

First, the star rating provides a heuristic analysis of the given target, but does not necessarily represent the actual run time detection and/or tracking performance. It is to provide some level of feedback to help guide developers to optimize their targets.

Second, the use of text as the primary source of image features for detection and tracking is not recommended. Text can lend itself to repetitive features from similar characters, and can also lead to false positive detections if more than one image contains the same text.

Suggestion is to utilize a background image for the text that can be used as an Image Target, paying close attention to our optimization guidelines: https://library.vuforia.com/articles/Solution/Optimizing-Target-Detection-and-Tracking-Stability. The areas of the background image where text will appear can be 'whited out' with image editing tools before being uploaded to the Vuforia Target Manager.

In your example, suggest that you remove the features associated with the text below the image and update the target in the Target Manager.

Hope this helps.

Thanks,

Vuforia Engine Support

Log in or register to post comments