Log in or register to post comments

Object Recognition Issues

January 17, 2016 - 12:49pm #1

Hello Vuforia Developers Team!

I'm using Vuforia 5.0.10 for my state examp, I'm developing an AR Art Installation. There are some issues pop-up, which I would like to disscuss and get fixed with your help. The overall scene contains approx. about 5.1 millions polligons. Most of them are static mesh particles. I have 2 simple animations included also into the scene.

I've fix more of the issues, however I'm  sitll struggiling with the following issues:
- to Optimize the geometry I've did standart Ocllusion Cullin operation in Unity - just not sure where to attach the OC object into the hierarchy. I've tried everywhere.. and the

- Trackable "name of data" lost (I used 2 different trackers - one small box and this toy, the box is working but the toy won't)
- WireframeBehaiviour  script.cs(41,24): warning CS0648 etc. please look at the printscreen
- I've did Occlusion Culling but I thing - somehow is not connected to Vuforia - AR camera. I'mean there is some data baked, but In my opinion is till really slow on the device also there is no special shaders, no realtime shadows etc... It sould work. Now when I upload the app - first loading really, really slow, and sometimes is crashing after that.

 

My machine:
Windows 10, Unity 5.02.4f1, Vuforia 5.0.10
Scanning device - Samsung S5

Could you suggest hot to fix those issues. Thank you in advance..

 

Object Recognition Issues

November 7, 2017 - 1:03pm #9

hi,

 

ive also got a problem, my console messages say that my trackable target has been found but the object i've chosen doesn't appear in the test screen 

Object Recognition Issues

April 30, 2016 - 4:50pm #8

Hi again

I don't understand how can I make a multitarget object with diferent image targets and yet all of them have to be referenced with only one 3D object situated on the side of the bottle.

I tried to separate the images like you said, and downloaded them all as image targets, and them I dragged them into scene, but the 3D object is only one, and i can't make it child of every image target, that's what i'm not understanding...

Sorry for my dumbness.

 

Object Recognition Issues

April 30, 2016 - 11:40am #7

Hello again,

Try to make several targets with simple [image target], skip for now object scan data, and the cylinder target. Try it more simple. There is an option where target data can be applied from several images. 

Check this materials:
https://developer.vuforia.com/library//articles/Training/Multi-Target-Guide
https://developer.vuforia.com/library//articles/Training/Image-Target-Guide
https://developer.vuforia.com/library//articles/Training/Text-Recognition-Guide

Try to make several good images from this wine label as I did into the example and we wil talk again :)
Best Regards

 

AttachmentSize
Image icon wine1.jpg1.3 MB

Object Recognition Issues

April 30, 2016 - 11:05am #6

This is great someone is helping me! Thanks.

Okay, so i've attached a picture of the front and back labels of the wine bottle. I tried to make a 3D scan and tested. On the test the green object appears only in certain sides, but even that, i tried to use it on unity and build it, and it should appear even only on that side, but it doesn't.

Next i tried with a cylinder target, wich is kinda working, but the image rating was 1 star. I followed the instructions to raise the contrast and it gave me a 2 star rating, which doesn't make a difference in what i'm trying. The cylinder target is recognized but the sphere around is always trembling... I don't know how to fix that.

I don't know which way i'll take, because a 3D object scan only on the labels side level seems promising but it's not working.

Can you understand this issue?

Best regards!

AttachmentSize
Package icon wine1.zip1.01 MB

Object Recognition Issues

April 21, 2016 - 12:13pm #5

Hi Jonh,

I would be glad to help you, with what I can! Can you upload a picture of the bottle?

1. In Vuforia object recognition documents and in the forum, they don not recommend to go scan glossy objects!

2. When you capturing the data on your device (Vuforia scanner app), after that make sure this data is working 100% correctly for the object, before proceeding forward and uploading it to your account.

3. If you still have issues, try to change the scanner device - Vuforia developer team strongly suggest to use some specific devices such as nexus, and samsung gallaxy please read some of the documents.

Good luck!

Object Recognition Issues

April 21, 2016 - 9:10am #4

Hi!

I'm trying to scan a wine bottle (which is glossy) with Vuforia Scanner. How do you recommend me to scan for it to work in Unity?

(I tried to scan several times with my Moto G, and the test detects it, but Unity won't...)

Best Regards

Object Recognition Issues

January 23, 2016 - 8:21am #3

Hello everyone,

I resolved it!

After you scan with Vuforia Scanner app - make 100% sure your Target will be regognized in TEST mode into different situations - ligh on, ligh off, distance, rotations etc.
The small toy I've tried to scan, was a bit glossy, each time this makes 100% different obsticles for the scanner to recognize the ecxatc form - because is captured as it is.
Also there is no much details where the scanner can attach his guid-points.

 

Object Recognition Issues

January 18, 2016 - 6:37am #2

Forgot to mension,

I've did different scenes with new .od scans. The last one was made with Huawei mobile device, Andoid 5.1 Lolypop
However the scan data is readable 100% into the device and durring the test - everything work perfect. After I share the scan data - for example to my e-mail, than upload it to Vuforia developer portal, and then download back as unity package - won't start into unity.

Everything's made like into the example
- Active data
- First Target to Camera
- AutoFocus - script
- Setup - web device proparties - readable and works
- Extendet trackick - on

Just everythings looks really fine to me, I'm using simple forms for content - spheres, cubes for the basic example. However looks strange because I've did another test with simple BOx, I scan with same device the box and works perfect in unity>??? can't understand.. why both work great in Vuforia scanner - app as test, but in Unity one of them is not working at all?

Box data was - 70% scanned ..
The Whale Toy - 100% scanned . .

Please look at the attached imgs.
I'm looking forward to hear your professional feedback. I'm planning to use Vuforia a lot in future - but I've to be sure will work coorrect with small projects before going any forward.

Log in or register to post comments