Log in or register to post comments

Sample not working - Unity3D

December 7, 2015 - 1:00pm #1

So I am trying out the Object Recognition sample for Unity and deploying it to an Android phone running Lollipop 5.1 but it is not recognizing the object at all. I went through the guide Vuforia posted on using the object recognition sample in unity. To iterate what I've already done

1. Downloaded the Scanner app and scanned an object.

2. Tested the object and it works perfect in the scanner app.

3. Uploaded the object to a database in the Target manager.

4. Created a license key for the app and set it on the ARCamera gameobject.

5. Imported the target database into Unity and set the Data Set and Object Target variables.

6. Checked "Load Data Set" and "Activate" in Unity on the AR Camera Database Load Behavior script.

I also reviewed the Player Settings in Unity to make sure the Rendering and Configuration are correct as described by Vuforia and tried two other object scans but none have worked.

The only thing different I have done is I used a 2nd Gen Moto G phone to do the scan instead of the two recommended phones. Though considering that the scan worked and the test on the scanner app worked I do not think this is the issue. I am using the same phone that did the scans for the Unity sample.


Windows 8.1

Tried Unity 5.1.2 (32bit) and Unity5.2.2(64bit)


If anyone has any tips it would be very helpful as I'd love to get this working! Thanks!

Log in or register to post comments