Log in or register to post comments

SmartTerrain Recognition

March 14, 2017 - 6:18am #1

Hi there, I've been using Vuforia for some time with Image Targets and I have no problems with them. However I wanted to learn how to use Smart Terrain.

I opened up the Penguin example, printed out the target cylinder, taped it to a soda can.

I built the app to work on my Samsung Galaxy J6, it recognizes the soda can as it should. However I cannot get the table scanning to work, it literally doesn't detect anything, and I tried multiple objects, boxes, cups, cans of vegetables, rubic cubes, etc. It just doesn't work. It's the same if I try to build a Smart Terrain project from scratch using na Image Target. It just builds completely nonsensical geometry and doesn't detect anything.

I tried it on my iPhone 5 and 6 - same results.

I tried those examples on a completely white, nontransparent or reflective table with nothing distracting the camera.

My question is - I've seen some tutorials on youtube where people have no problem detecting some shapes. What am I doing wrong? Is it because of my devices? SG J6, iPhone 5, 6, iPad mini 2, it's the same with just PC with webcam.

My question to other developers: I need to use this technology in a commercial project - the video demo presents it as working very well with semi-fast recognition when scanning the table. How reliable is it in real life development and not in a promo video?

I'm using the latest Vuforia with Unity 5.4.3f1

SmartTerrain Recognition

May 22, 2017 - 3:54pm #4

Hello,

Apologies for any confusion, but the Penguin and Find the Penguin samples are only provided as part of the vuforia-samples-practices-unity-6-2-10.zip file.

https://developer.vuforia.com/downloads/samples

Thanks.

SmartTerrain Recognition

May 22, 2017 - 6:27am #3

Im also looking fo this as the Books example is only available when you download the zip file

SmartTerrain Recognition

March 27, 2017 - 9:34am #2

Similar issue. Hopefully someone will see this thread and share some insight. By the way, where did you find the Penguin Example download? I can't find it anywhere...

Log in or register to post comments