Log in or register to post comments

Positional deviation on model target using Hololens 2

SDK 10.0
January 3, 2022 - 5:04am #1

Hi there,

I am working with the Hololens 2  using Vuforia through Unity.

When using my computer webcam the virtual model positioning over the real model is perfect. However, when using the same code for the Hololens 2 there is a positional deviation between the virtual model and the real model, which is not constant (sometimes is deviated to the left, sometimes to the right...). Also, when moving the real object with the webcam the virtual model follows well but with the Hololens 2 looses the track much more. When generating the model target on the "Model Targer Generator" I considered the "Hololens view", still there is no difference.

Additonally, I cannot run this model target app on the Hololens 2 while running the "Dynamics 365 Remote Assit" (in order to share what I seeing with my colleges). Wondering if it is related with the vuforia code since with other apps is not happening.

Thanks for your time.

Edit 1: I am currently using the 2020.3.20f1 Unity version

 

 

SDK Version: 

Positional deviation on model target using Hololens 2

January 18, 2022 - 6:35am #3

Thanks Patrick for your quick reply,

 

Regarding the second question (running the model target app on the Hololens 2 while running the "Dynamics 365 Remote Assit") will also be fixed with this new realease or it is a permanent issue that has never been done before?

 

Thanks,

 

Eduardo

Positional deviation on model target using Hololens 2

January 5, 2022 - 8:45am #2

Hey there,

 

If you're using OpenXR, it might be a known compatibility issue that will be fixed in the next release (v10.4.x) of Vuforia Engine. The current issue is tracked here: https://developer.vuforia.com/forum/hololens/hololens2-imagetarget-world-center-issue#comment-73837

 

Kind regards,

Patrick Scheper

Technical Community Manager

Log in or register to post comments