Log in or register to post comments

OpenGL ES create dynamic shadows

June 15, 2012 - 2:45am #10

I want some 3d objects to rotate and for a better look, I need some dynamic shadows, that would be visible on the object.

Can anyone recommend a easy way to do it? It could be iOS or Android.

There are some frameworks that create shadows, but they are too hart do integrate with QCAR.

I bump this subject because i

January 10, 2013 - 8:56am #9

I bump this subject because i need dynamic lighting for AR too 

Hi, this is a fairly

January 10, 2013 - 9:05am #8

Hi, this is a fairly advanced topic in OpenGL programming;

of coure using Unity 3D would make your life much easier (as these kind of effects are provided out-of-the-box);

but if you want to do it natively, there are a few good tutorials about this subject in the internet; for example I found this one (but you can find many others):

http://blog.shayanjaved.com/2011/05/20/android-opengl-es-2-0-shadow-mapping/

 

 

I'm using unity but i don't

January 10, 2013 - 9:23am #7

I'm using unity but i don't know why it didn't work ... in fact i have  a box win an extrude in it and she is an animation of rotation and there is no self shadow projected .... i don't understand why 

Which devices are you testing

January 10, 2013 - 9:28am #6

Which devices are you testing on?

Here are some instructions for setting up your scene to render shadows on a mobile device - http://forum.unity3d.com/threads/163782-Mobile-Shadows-Anyone-got-them-to-work

Hi, if it is a Unity 3D

January 10, 2013 - 9:31am #5

Hi, if it is a Unity 3D related question, I would invite you to post it in the Unity section of our Forum;

 

One useful resource to read is this:

http://docs.unity3d.com/Documentation/Manual/Shadows.html

Among other things, the article above explains that shadows require Unity Pro license, and also that on some Android devices (with Tegra-based chips), shadows may not work.

In addition to that, shadows are affected by many settings, as explained in the Unity article above...

i fixed it :) my scene was

January 11, 2013 - 1:36am #4

i fixed it :) 

my scene was too big in fact .... but when i export it in .apk for my android , in AR there is no self projected shadow.
 

OK, so are you seeing it

January 11, 2013 - 2:07am #3

OK, so are you seeing it correctly in PlayMode but not when running the APK on the device ?

or did I misunderstood ?

yes exaclty ( sorry for my

January 11, 2013 - 2:51am #2

yes exaclty ( sorry for my bad english ^^ )

OK, thanks for the

January 11, 2013 - 4:54am #1

OK, thanks for the confirmation;

then as I said before, there are chances that it is not supported by your device (e.g. if it is a Tegra-based, like the Unity website mentions);

maybe it would be a good idea to check directly on the Unity 3D forum, as I presume you are not the only one experiencing problems with shadows in Unity on Android device.

 

Log in or register to post comments