Log in or register to post comments

Texture mapping not working

December 21, 2012 - 2:00pm #1

Hi, I tried out the imageTargets sample app, by replacing the default teapot with a castle model obtained from here:
http://www.turbosquid.com/FullPreview/Index.cfm/ID/552087

I followed this: https://developer.vuforia.com/forum/faq/android-how-do-i-replace-teapot
and a few other topics here about replacing the default models with custom models using obj2opengl.

My problem is, when i augmented the castle model or the banana model, the 3D model does appear, but the textures seem out of place and basically just wrong. Here's a screenshot: http://s7.postimage.org/dhsxrfj5n/Screenshot_2012_12_22_03_16_44.png

I'm really new to AR and Vuforia, so any help will be really appreciated! I plan to make a home decoration app, using furniture and other models.

Texture mapping not working

March 22, 2017 - 3:44am #4

Hi Rate,

I am also facing same problem in castle. How to solve it?

your help is valuable for me.

Hi natToc, thanks fr the

December 22, 2012 - 7:34am #3

Hi natToc, thanks fr the comments, and glad to hear that you found the answer to your problem!

Never mind, the textureindex

December 22, 2012 - 4:04am #2

Never mind, the textureindex in imagetargets.cpp was incorrectly set, so it was mapping the textures of brass teapot instead of the actual castle...found a similar problem in another thread and solved mine
The community support for vuforia is really good!

Log in or register to post comments