Log in or register to post comments

after updating to 2.8 i get an error

December 18, 2013 - 3:41am #1

After Updating to Vuforia 2.8 i get this error:

 

Assets/Qualcomm Augmented Reality/Scripts/DefaultTrackableEventHandler.cs(50,52): error CS0117: `TrackableBehaviour.Status' does not contain a definition for `EXTENDED_TRACKED'

after updating to 2.8 i get an error

December 19, 2013 - 2:46am #9

You're welcome.

after updating to 2.8 i get an error

December 18, 2013 - 11:37pm #8

hmm first time I deleted that it caused a problem. thanks though

after updating to 2.8 i get an error

December 18, 2013 - 11:35pm #7

  ImageTracker imageTracker = (ImageTracker)TrackerManager.Instance.GetTracker(Tracker.Type.IMAGE_TRACKER);

would become:

  ImageTracker imageTracker = TrackerManager.Instance.GetTracker<ImageTracker>();

as I said before.

 

 

after updating to 2.8 i get an error

December 18, 2013 - 3:05pm #6

looks like i fixed one error but not this one

 

Assets/Scripts/ImageTargetsScripts/ImageTargetsMenu.cs(199,98): error CS0246: The type or namespace name `IMAGE_TRACKER' could not be found. Are you missing a using directive or an assembly reference?
 

after updating to 2.8 i get an error

December 18, 2013 - 3:01pm #5

so what would 

ImageTracker imageTracker = (ImageTracker)TrackerManager.Instance.GetTracker(Tracker.Type.IMAGE_TRACKER);

 

become? that is where the error is

after updating to 2.8 i get an error

December 18, 2013 - 2:53pm #4

Have you checked the migration guide ?

https://developer.vuforia.com/resources/dev-guide/api-changes-vuforia-v28-unity

https://developer.vuforia.com/resources/dev-guide/migrating-your-unity-project

The Type class has been removed; 

you can get a specific Tracker by replacing this code:

TrackerManager.Instance.GetTracker( tracker type )

with:

TrackerManager.Instance.GetTracker<ImageTracker>();

 

after updating to 2.8 i get an error

December 18, 2013 - 1:28pm #3

Thank you for your reply. I did everything and now i receive these errors:

 

error CS0117: `Tracker' does not contain a definition for `Type'

 

Assets/Scripts/ImageTargetsScripts/ImageTargetsMenu.cs(199,87): error CS1501: No overload for method `GetTracker' takes `1' arguments

after updating to 2.8 i get an error

December 18, 2013 - 3:53am #2
Log in or register to post comments