Log in or register to post comments

App crash because of QCAR::init()

April 15, 2013 - 11:54pm #1

Hi, 

I have used Vuforia SDK library (libExtensionVuforia.a) for image recognition.

I also added QCAR headers in my project.

But, when i lanuch the image recognition part, it is throwing exception of QCAR::init(). Sometimes app gets crashed.

I found following exception log:

 

2013-04-16 12:04:15.289 SamlpleAR[2500:707] INFO/AR(2500) 2013-04-16 12:04:15: QCAR SDK version 2.0.29

 

configureVideoBackground PORTRAIT with aspect: nan 

Configure Video Background : Video (0,0), Screen (640,832), mSize (832,0) 

2013-04-16 12:04:15.476 SamlpleAR[2500:707] ERROR/AR(2500) 2013-04-16 12:04:15: VideoBackgroundConfig with screen size of zero received, skipping config step

2013-04-16 12:04:15.525 SamlpleAR[2500:707] DEBUG/AR(2500) UIView has CAEAGLLayer class

2013-04-16 12:04:15.527 SamlpleAR[2500:707] DEBUG/AR(2500) UIView responds to selector renderFrameQCAR

QCAR::CameraDevice::getInstance().init() 

configureVideoBackground PORTRAIT with aspect: 1.333333 

Configure Video Background : Video (480,360), Screen (640,832), mSize (832,1109) 

 

(lldb) bt

* thread #1: tid = 0x1c03, 0x3774e238 libobjc.A.dylib`objc_exception_throw, stop reason = breakpoint 1.1

    frame #0: 0x3774e238 libobjc.A.dylib`objc_exception_throw

    frame #1: 0x352365b8 AVFoundation`-[AVCaptureVideoDataOutput setVideoSettings:] + 396

    frame #2: 0x001f1706 SamlpleAR`QCAR::init() + 547410

(lldb) 

 

Please suggest how to resolve this.

 

Thanks in advance.

 

Kind regards,

Kishan Lal

 

 

 

App crash because of QCAR::init()

April 21, 2013 - 12:12am #4

Hi Absaruddin,

first: this thread mentions a problem with an iOS device, not Android like in your case.

Could you create a New thread with your question on the HTC Hero ?

Thanks.

 

App crash because of QCAR::init()

April 20, 2013 - 3:16am #3

Needed the same help i am also having this problem cant understand what the issue about ..i am running on htc Hero v 2.1.1.

App crash because of QCAR::init()

April 18, 2013 - 2:49am #2

Please can you provide more details.

Do the sample applications work ok?

Could it be something in your code causing this?

N

Log in or register to post comments