Log in or register to post comments

Error with ndk-build in ndk-r5

January 4, 2011 - 3:43am #1

I just installed the new version of the AR SDK and everything works great, moreover, some applications that before have problems, now work.

However, I haven't updated to ndk-r5, because when I try to build my apps it says:

/.../obj/local/armeabi/objs-debug/.../.o.d:1: *** Target pattern contain no '%'. Stop.

The samples apps build ok but not mines. Any ideas?

Thanks,

Re: Error with ndk-build in ndk-r5

January 4, 2011 - 7:03am #3

:eek: THAT IS!! You are the best!
Thank very much!

Re: Error with ndk-build in ndk-r5

January 4, 2011 - 6:50am #2

Hmm, I haven't seen that exact error, but if you're using NDK r5 on Windows you need to make a small change to your existing Android.mk file (located in the jni folder). Add this line:

QCAR_LOCAL_PATH := $(shell cygpath -m $(LOCAL_PATH)/../build/lib/$(TARGET_ARCH_ABI))

And update the LOCAL_LDLIBS variable to replace this:

-L$(LOCAL_PATH)/../../../build/lib/$(TARGET_ARCH_ABI) \

with this:

-L$(QCAR_LOCAL_PATH) \

You can look at the Android.mk files included in the 0.10.0 samples for an example.

- Kim

Log in or register to post comments