Log in or register to post comments

example app ImageTargets shows black screen on Xperia X10

November 9, 2010 - 10:43am #1

Hi,

I built and run the ImageTargets app on Xperia X10 (android 2.1) and it shows a splash creen and thewn a black screen only, no error messages. I attached logcat traces (err.txt).

Is Xperia X10 supported?

thanks
Lajos

Re: example app ImageTargets shows black screen on Xperia X10

December 4, 2010 - 7:44am #10

I also confirm this works on my Xperia X10i with the latest Android 2.1 update. Could someone add a link to this thread on the main "Supported Devices" sticky? I was just continually checking that sticky every few days and stumbled across this thread entirely by accident - when it does actually work!

Kind Regards,
Phil.

Re: example app ImageTargets shows black screen on Xperia X10

November 17, 2010 - 10:38am #9

Hi,

The constant was MODE_OPTIMIZE_SPEED instead of MODE_OPTIMIZED_SPEED.
ImageTargets works now.

Thanks
Lajos

Re: example app ImageTargets shows black screen on Xperia X10

November 16, 2010 - 7:08pm #8

Please try changing the value of QCAR::CAMERADEVICE:: to MODE_OPTIMIZED_SPEED in the file QCARSampleActivity.cpp file in the jni folder of the Shared project.

Thank you.

Re: example app ImageTargets shows black screen on Xperia X10

November 13, 2010 - 11:09am #7

Hi,

x10i
2.1-update1

br
Lajos

Re: example app ImageTargets shows black screen on Xperia X10

November 12, 2010 - 7:59am #6

Thanks for the logs. One last question - what version of the Xperia do you have, the X10 or the X10a? Also what version of the Android OS is on it?

- Kim

Re: example app ImageTargets shows black screen on Xperia X10

November 10, 2010 - 9:03am #5

New log attached zipped
br
Lajos

Re: example app ImageTargets shows black screen on Xperia X10

November 10, 2010 - 8:55am #4

You can download the new log from here:
http://www.kotiposti.net/lkelemen/qcar_imagetargets_errorlog.zip

(I tried to attach to this message but it gets corrupted)

br
Lajos

Re: example app ImageTargets shows black screen on Xperia X10

November 9, 2010 - 6:05pm #3

Although, I would be curious to see more of your log output. I don't see any errors in the output provided. Could you capture all of the output, from app run to app end, in a single file?

Thanks!

- Kim

Re: example app ImageTargets shows black screen on Xperia X10

November 9, 2010 - 6:02pm #2

This device is not currently supported. Please see the Device Compatibility sticky for more info:

http://ar.qualcomm.at/node/2000017

- Kim

Log in or register to post comments