Topic locked

Failed to initialize QCAR. Exiting.

June 3, 2013 - 10:28am #1

Hi,

I've integrated ImageTargets sample into my Android app project. It took some time but finally it was successfully built.

I've added the content of ImageTargets.java to my MainActivity and copied all the other files I think are relevant.

When I run it, I get the following message: E/QCAR(10134): InitQCARTask::onPostExecute: Failed to initialize QCAR. Exiting.

Do I have a way to understand why was this error generated?

Thank you,

 

Failed to initialize QCAR. Exiting.

March 9, 2015 - 6:22am #6

Great ;-)

Failed to initialize QCAR. Exiting.

March 9, 2015 - 6:05am #5

Problem Solved!!!! I just added 

QCAR.deinit();

 

Failed to initialize QCAR. Exiting.

March 9, 2015 - 2:57am #4

I have exactly this problem.My ImageTargets.java is called twice and during my second call I receive this logcat error:

" InitQCARTask::onPostExecute: Failed to initialize QCAR. Exiting."

How will I resolve it please?

Failed to initialize QCAR. Exiting.

September 11, 2013 - 3:01am #3

I have the same problem. I try "ImageTargets" sample without modifying anything.

What should i do? 

09-11 09:41:25.722: I/QCAR(841): Activity is in PORTRAIT
09-11 09:41:25.752: D/QCAR(841): ImageTargets::onResume
09-11 09:41:25.952: I/AR(841): QCAR has been initialized successfully
09-11 09:41:26.032: I/AR(841): QCAR SDK version 2.6.10
09-11 09:41:26.163: I/Choreographer(841): Skipped 32 frames!  The application may be doing too much work on its main thread.
09-11 09:41:27.112: D/dalvikvm(841): GC_FOR_ALLOC freed 621K, 13% free 5110K/5852K, paused 30ms, total 30ms
09-11 09:41:27.112: I/dalvikvm-heap(841): Grow heap (frag case) to 5.382MB for 293423-byte allocation
09-11 09:41:27.162: D/dalvikvm(841): GC_FOR_ALLOC freed 912K, 27% free 4484K/6140K, paused 44ms, total 44ms
09-11 09:41:27.242: E/QCAR(841): InitQCARTask::onPostExecute: Failed to initialize QCAR. Exiting.
 
 
 
Thank you

Failed to initialize QCAR. Exiting.

June 3, 2013 - 11:34am #2

Hi, you need to debug and see why exactly it is failing.

One common reason is if you (for some reason) initialize QCAR twice in your application, but there might be other reasons too.

That error message alone is not sufficient to understand the root of the error..

Topic locked