Log in or register to post comments

Failed to Initialize Vuforia

February 21, 2016 - 2:08pm #1
My Vuforia-enabled Unity project/scene runs fine in the Unity editor (5.0.2f3) but when the .apk is built and run on Android (v5.1.1 on Samsung Galaxy s6) it just shows a black screen with "Failed to Initialize Vuforia" error.  Is this a known error, and what should I look for in project or player settings to counteract this behavior?
 
Thanks,
--Marc

Fix

January 31, 2018 - 2:30am #6

Uninstalling the app from the device and building again did the job for me.

Failed to Initialize Vuforia

October 16, 2017 - 8:11pm #5

Did you find an answer for this?

Failed to Initialize Vuforia

February 26, 2017 - 6:58pm #4

Did you find an answer for this?

Failed to Initialize Vuforia

September 27, 2016 - 5:59pm #3

Are there any other possible solutions? 

Galaxy S6 Active

Unity 5.3.0.0

Vuforia 6.0.117

The most recent Cardboard for Unity

 

I have gone through every possible adjustment variable I could find to try to try to make this work:

I adjusted sdk versions: android:minSdkVersion="19" android:targetSdkVersion="22"

 

I made sure that all my settings matched this:

https://library.vuforia.com/articles/Solution/Integrating-Cardboard-to-the-ARVR-Sample

 

I also followed these instructions for Android:

https://developer.vuforia.com/forum/faq/unity-player-settings

 

I even changed AndroidManifest.xml to be AndroidManifest-Vuforia.xml

 

The program compiles and runs perfectly on my webcam, but the second I install it on my phone and run it, I keep getting the same Vuforia Initialization Error no matter what I do. And yes, I made sure to give the app permission to use the camera.

Failed to Initialize Vuforia

February 25, 2016 - 11:33pm #2

If you are using Unity 5, I would recommend upgrading to at least to Unity 5.1 (5.1.4) or 5.2 (5.2.3);

see:

https://developer.vuforia.com/library/articles/Solution/Vuforia-Supported-Versions

 

also check that your Unity Build / Player Settings are correctly set (in particular the Graphics API should be set to OpenGL ES 2.0):

see:

https://developer.vuforia.com/forum/faq/unity-player-settings

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/vuforia-50-and-unity-5

 

 

Log in or register to post comments