Log in or register to post comments

Installation Issue

January 3, 2011 - 5:29am #1

Hi,

I am a new user, trying to install the SDK by following the instructions in Step 1: Set-up the Development Environment https://ar.qualcomm.com/qdevnet/sdk/320

Under the Android ADT step, I can't install the Developer Tools. I got the following error message when I want to install it.

--------------------------------------------------------------------------

Cannot complete the install because one or more required items could not be found.
Software being installed: Android DDMS 8.0.1.v201012062107-82219 (com.android.ide.eclipse.ddms.feature.group 8.0.1.v201012062107-82219)

Missing requirement: Android DDMS 8.0.1.v201012062107-82219 (com.android.ide.eclipse.ddms.feature.group 8.0.1.v201012062107-82219) requires 'org.eclipse.jdt.core 0.0.0' but it could not be found

--------------------------------------------------------------------------

May I know what the problem is? Trying to search from the Internet and Eclipse, cant find any useful information regarding the error.:confused: For your information, I have set the path to the value suggested in the instructions and follow all the steps and environment variables suggested.

Hope to hear from the expert soon. Thanks. :)

Re: Installation Issue

January 3, 2011 - 7:19am #8

Excellent, thanks for the tip!

- Kim

Re: Installation Issue

January 3, 2011 - 7:16am #7

Hi all,

Thanks for all the replies. Found a way to solve it. Instead of installing Android DDMS, Android Development Tools and Android Hierarchy Viewer in one go as suggested in the instructions, try to install Android DDMS first. It contains the required feature (org.eclipse.jdt.core).

Once Android DDMS has been installed and restarted, you can continue to install the remaining two. :D

Re: Installation Issue

January 3, 2011 - 6:59am #6

Hmm, perhaps you should try installing the Java version of Eclipse, it also works with the SDK and might solve these issues. Choose the Eclipse IDE for Java Developers on the Eclipse Downloads page: http://www.eclipse.org/downloads/

- Kim

Re: Installation Issue

January 3, 2011 - 6:47am #5

Hi,

Thanks for the suggestions but it fails. I can see the java options but the following errors are generated when I want to install it.

--------------------------------------------------------------------------

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6 (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6)
Software currently installed: Shared profile 1.0.0.1284707879636 (SharedProfile_epp.package.cpp 1.0.0.1284707879636)
Only one of the following can be installed at once:
Equinox Framework Admin 2.0.0.v20100503 (org.eclipse.equinox.frameworkadmin 2.0.0.v20100503)
Equinox Framework Admin 1.0.100.v20090520-1905 (org.eclipse.equinox.frameworkadmin 1.0.100.v20090520-1905)
Cannot satisfy dependency:
From: Shared profile 1.0.0.1284707879636 (SharedProfile_epp.package.cpp 1.0.0.1284707879636)
To: org.eclipse.equinox.frameworkadmin [2.0.0.v20100503]
Cannot satisfy dependency:
From: Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6 (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6)
To: org.eclipse.jdt.junit [3.5.2.r352_v20100113-0800]
Cannot satisfy dependency:
From: Java Development Tools JUnit support 3.5.2.r352_v20100113-0800 (org.eclipse.jdt.junit 3.5.2.r352_v20100113-0800)
To: bundle org.eclipse.equinox.frameworkadmin [1.0.100,2.0.0)

--------------------------------------------------------------------------

Re: Installation Issue

January 3, 2011 - 6:11am #4

After some Internet search, I found that you can have both, Java and C/C++, at the same Eclipse installation.
So you have to go to "Help->Install new Software..." and add the repository of your Eclipse version, this works for me (Eclipse Galileo): http://download.eclipse.org/releases/galileo

Then install the languages you want inside "Programming Languages", I hope you should have Java in the list as I have C/C++.

Regards,

Re: Installation Issue

January 3, 2011 - 5:57am #3

Hi,

Try with the steps from "Android developers" page: http://developer.android.com/sdk/installing.html, they have more details about the process.
I hope it should help you.

Anyway, I think that "org.eclipse.jdt.core" is a Java component so with C/C++ version you shouldn't have. My version of Eclipse doesn't have C/C++, I have installed only with Java and all AR SDK works perfect.

Regards,

Re: Installation Issue

January 3, 2011 - 5:53am #2

Just check the feature list for Eclipse IDE for C/C++ Developers, org.eclipse.jdt.core is not in the list. How can I install it manually? :) Thanks.

org.eclipse.cdt 7.0.0
org.eclipse.cdt.debug.ui.memory
org.eclipse.cdt.mylyn
org.eclipse.cdt.p2
org.eclipse.cdt.platform 7.0.0
org.eclipse.cvs 1.1.0
org.eclipse.epp.package.common.feature
org.eclipse.equinox.p2.user.ui 1.1.0
org.eclipse.help 1.1.0
org.eclipse.mylyn.bugzilla_feature
org.eclipse.mylyn.context_feature
org.eclipse.mylyn.ide_feature
org.eclipse.mylyn.team_feature
org.eclipse.mylyn.wikitext_feature
org.eclipse.mylyn_feature
org.eclipse.platform 3.6.0
org.eclipse.rcp 3.6.0

Log in or register to post comments