Log in or register to post comments

Problem in running the InmageTargets sample application

March 25, 2011 - 3:13am #1

Hi every body, I am new to Augmented Reality. I am tryig to run the ImageTarget application as a start-up but having problem. I am using the Android device (http://www.boardset.com/products/products_v210.php). I connected to the PC through usb and install the apk file on the device using Eclipse by going through the Setup environment tutorial given on the qualcomm dev.
An error message comes:
"Network connection required to initialize camera settings.Please check your connection and restart the application. If you are still experiencing problems, then your device may not be currently supported."
A simple hello world android application is running on the device.
Please help me, I shall be grateful.
Thanks!

Re: Problem in running the InmageTargets sample application

May 2, 2011 - 3:43pm #9

The SDK requires a connection to a Qualcomm server to retrieve device-specific calibration data, and to send anonymous SDK usage data for purposes of improving the SDK. Additional info can be found in the AR SDK and AR Extension for Unity License Agreement at https://ar.qualcomm.com/legal/license/

Try deleting the application from your device, connecting to the internet, and running the application again. It should work offline after that first connected run. Let us know if you are still having problems.

- Kim

Re: Problem in running the InmageTargets sample application

April 29, 2011 - 11:37am #8

Is the device connected to the internet when you see this error message? Also, are you using the Unity Extension or the regular QCAR SDK?

Finally, make sure that you have upgraded to the latest 1.0.0 release if you haven't already! This is required for all the supported devices to work.

Thanks,

- Kim

Re: Problem in running the InmageTargets sample application

March 27, 2011 - 5:36pm #7

Thanks a lot!
Arshad

Re: Problem in running the InmageTargets sample application

March 27, 2011 - 10:28am #6

This device is not supported, QCAR applications will not currently run on it. As robertross mentioned, you can see the full list of currently supported devices here: http://ar.qualcomm.com > Supported Devices (section on left).

- Kim

Re: Problem in running the InmageTargets sample application

March 25, 2011 - 8:46pm #5

Thanks for your response,
I see the specification of the device and also discussed with the vendor, they mentioned that the device is supported. I also connected the device with internet before running the application but the same error.
I sent the apk file and get a reply from the techinal support of vendor as:

"I have run your program. I think that different from your an APK(QCAR) device driver and a camera port.
It is not initialize a Camera port. So that can’t open device from camera.
Anyway you have to modify camera port and the initializing value JNI."

but I could not understand what to do...

Please if you could help me in this regard...

Once again thanks!

Re: Problem in running the InmageTargets sample application

March 25, 2011 - 5:38am #4

If it's not in the supported device list
https://ar.qualcomm.com/qdevnet/sdk > Supported Devices
Then the program will not work.
Qualcomm has this system where the device fires a query somewhere to check if the device is supported. If it's not on the list it will not start up.

This is also the reason why the device must be connected to the internet on first run of the application.

Log in or register to post comments