Log in or register to post comments

problems running image targets in eclipse

February 28, 2011 - 7:45am #1

Hi.I get this error when i try to clean the project :

Errors occurred during the build.
Errors running builder 'Integrated External Tool Builder' on project 'ImageTargets'.
The file does not exist for the external tool named Import QCAR (Win).
The file does not exist for the external tool named Import QCAR (Win).

What can i do to fix this problem ?

Re: problems running image targets in eclipse

March 1, 2011 - 8:33am #5

That will not be a problem since i migrated to Unity . Also great API and i wish that you will make one for IOS since i can't fine one that works.

Re: problems running image targets in eclipse

March 1, 2011 - 6:09am #4

Just be careful, because every time you build the native code with ndk-build the libQCAR.so files will be deleted. That's why we have the scripts there, so you don't have to copy those files by hand every time you build the native library!

- Kim

Re: problems running image targets in eclipse

March 1, 2011 - 6:05am #3

I've figured this out.I imported the files from the script manually .

Re: problems running image targets in eclipse

February 28, 2011 - 11:58am #2

There are a few things to look at here. Start by right-clicking on your project in the Package Explorer and selecting Properties. Go to the Builders section. First, make sure that the correct Import QCAR builder is checked for your OS, either Win for Windows or bash for Mac/Linux.

Next, select the appropriate builder and hit Edit... In the Working Directory and/or Arguments fields, make sure the project name matches your Eclipse project's name (e.g. workspace_loc:/MyProject).

Finally, you can open the source of the script this builder is calling. It's located in a hidden folder in the Eclipse project named .externalToolBuilders. Open either copyQCARLibs.bat (Windows) or copyQCARLibs.sh (Mac/Linux) and make sure the paths work for your project setup.

- Kim

Log in or register to post comments