Log in or register to post comments

Project not pushing to Android or iOS

July 28, 2015 - 6:53am #1

OS Version 10.10.4

Unity 5.0.1f1

Vuforia 4.2.3

XCode 6.4

Testing on iPad Air 2 (8.4)

Testing on Hudl 2 (4.4.2)

 

I've created a project in Unity that includes the Vuforia package for Augmented Reality.

I've built the project how I normally would and got it to a stage where I wanted to test it on a device.

Initially, I tested it on the Android device; I built the .APK then put it onto the device, installing to and running it.

However, when I try to run it, the screen will go black (like it does when it loads) but then closes and returns to the devices home screen.

I checked the settings on my project etc and tried a couple more times but with the same result.

I then duplicated the project, switched platforms to iOS and exported it to XCode. After setting that all up normally, I clicked Run.

It failed and showed 3 errors all declaring "Semantic Issue   Use of undeclared identifier 'QCARUnityPlayer'". (see Attached)

I went back the the project and searched for the QCARUnityPlayer but I didnt see anything wrong with it (I'd not changed it before hand and it was the same as in previous working projects)

Has anyone else encountered this problem? I've never come across it before so it's a little baffling

AttachmentSize
Image icon iOSProblem.jpg162.97 KB

Project not pushing to Android or iOS

July 31, 2015 - 1:48am #3

Hi, 

Thanks for the reply.

I managed to fix the issue, it turns out it was a problem with the Graphics API; once I set it to Automatic in the Player Settings, it worked fine.

Project not pushing to Android or iOS

July 30, 2015 - 8:05pm #2

It sounds like an issue with accessing the Vuforia library in the project. Can you try creating a new Unity project and import the ImageTargets sample and build to the device?

 

Log in or register to post comments