Log in or register to post comments

QCAR Initialization Issue

October 13, 2016 - 10:36am #1

Hello, I'm getting the following error when I try to initialize Vuforia during runtime. It all compiles fine, but fails to run on the device.

10-13 10:22:32.617 3563-3664/com.xperiel.android.apiintegration I/AR: QCAR has been initialized successfully

10-13 10:22:32.617 3563-3563/com.xperiel.android.apiintegration I/AR: QCAR SDK version 5.0.10

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410] JNI DETECTED ERROR IN APPLICATION: GetStringUTFChars received NULL jstring

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]     in call to GetStringUTFChars

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]     from int com.qualcomm.QCAR.QCAR.progressiveInit()

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410] "main" prio=5 tid=1 Runnable

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]   | group="main" sCount=0 dsCount=0 obj=0x758c7390 self=0xf5064500

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]   | sysTid=3563 nice=0 cgrp=default sched=0/0 handle=0xf77d5d54

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]   | state=R schedstat=( 258013588 48281091 353 ) utm=16 stm=9 core=0 HZ=100

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]   | stack=0xff741000-0xff743000 stackSize=8MB

10-13 10:22:32.657 3563-3563/com.xperiel.android.apiintegration A/art: art/runtime/java_vm_ext.cc:410]   | held mutexes= "mutator lock"(shared held)

I also tried your lastest sdk, but fails on same error. This used to work fine.

Ideas?

Log in or register to post comments