Log in or register to post comments

several targets to track

March 20, 2012 - 4:07pm #1

Hello!

I would like to track several targets.

My first approach was to define target for target additionally.

using the first target worked:

[qUtils addTargetName:@"OOE1" atPath:@"OOE1.xml"]; //OK

adding a second target worked

[qUtils addTargetName:@"OOE2" atPath:@"OOE2.xml"]; //OK

but adding a third target failed:

[qUtils addTargetName:@"OOE3" atPath:@"OOE3.xml"]; //NOT OK

If I am using OOE3 target as the only target, OOE3 target is working.

Hence, if i am generating a .dat and .xml which has all targets in one .dat and .xml file, OOE3 is not tracked in my app. Only if i am using OOE3 as the ONLY target.

any ideas why!?!

it seems that if i am adding more than two targets, via qUtils addTargetName: the targets are not tracked anymore. only i f i am using them in ONE file. but, as told before, it seems then that ONE target which is added to my targets bucket is never tracked / only, i am using this image exclusively. and yes, the images are very similar to each other. could this be a problem?

thx

Re: several targets to track

March 21, 2012 - 7:02am #2

Hi Alex,

The addTargetName method just adds the details of the target to a list, for loading later. The list is used by the OverlayViewController to provide a list of targets to the user to select. The target then gets loaded using loadDataSet: and activated using activateDataSet:

The first target in the list is loaded automatically at startup. Maybe you are only ever actually using OOE1, and because it is similar to OOE2, it works and disimilar to OOE3 it fails.

If you have retained the OverlayViewController functionality try tapping the screen, scolling down the options until 'Select Target' is visible, and then choose a new target from the list.

If you want to load datasets automatically then you need to remove the overlay list and add your own code to deactivate/unload/load/activate the datasets.

Log in or register to post comments