Log in or register to post comments

some problem with Imagetarget...

February 19, 2011 - 5:52am #1

Hi all!

I followed SDK "Get Started" perfectly and the phone just told me "has stopped unexpectedly!"

This is my build log

[2011-02-18 17:48:08 - ImageTargets] Android Launch!
[2011-02-18 17:48:08 - ImageTargets] adb is running normally.
[2011-02-18 17:48:08 - ImageTargets] Performing com.qualcomm.QCARSamples.ImageTargets.ImageTargets activity launch
[2011-02-18 17:48:08 - ImageTargets] Automatic Target Mode: using device 'HT06TP800483'
[2011-02-18 17:48:09 - ImageTargets] Uploading ImageTargets.apk onto device 'HT06TP800483'
[2011-02-18 17:48:10 - ImageTargets] Installing ImageTargets.apk...
[2011-02-18 17:48:13 - ImageTargets] Success!
[2011-02-18 17:48:13 - ImageTargets] Starting activity com.qualcomm.QCARSamples.ImageTargets.ImageTargets on device HT06TP800483
[2011-02-18 17:48:13 - ImageTargets] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.qualcomm.QCARSamples.ImageTargets/.ImageTargets }

and the phone is nexus one 2.2.1

What's the problem?! Help!

Re: some problem with Imagetarget...

February 19, 2011 - 6:18am #2

You'll want to take a look at the runtime log to find the error. In Eclipse, open the DDMS perspective and look at the LogCat section along the bottom. You may have to select your device in the Devices window to get the output. Now run the application and look for any errors.

The typical problem here is missing either libImageTargets.so or libQCAR.so in the libs folders. The first is built via ndk-build, and the second is added by an Eclipse builder. You can see the builders by right-clicking on your project and choosing Properties, then Builders. Make sure you've selected the correct one for your OS (bash for Mac/Linux).

- Kim

Log in or register to post comments