Log in or register to post comments

Testing ImageTargets

June 9, 2011 - 4:22am #1

Hi,

I am trying to run the ImageTargets sample application but I am not able to see the teapot.

I have following set-up:

OS: Windows 7 Home Premium
Device: Samsung Galaxy GT-I9000
Android: v2.2

Android SDK and AVD manager in Eclipse shows 'Target Name' as Android 2.2 and 'API level' as 8.

I am getting the following log:
[2011-06-09 12:07:27 - ImageTargets] ------------------------------
[2011-06-09 12:07:27 - ImageTargets] Android Launch!
[2011-06-09 12:07:27 - ImageTargets] adb is running normally.
[2011-06-09 12:07:27 - ImageTargets] Performing com.qualcomm.QCARSamples.ImageTargets.ImageTargets activity launch
[2011-06-09 12:07:27 - ImageTargets] Automatic Target Mode: using existing emulator 'emulator-5554' running compatible AVD 'samsung_g'
[2011-06-09 12:07:27 - ImageTargets] Uploading ImageTargets.apk onto device 'emulator-5554'
[2011-06-09 12:07:39 - ImageTargets] Installing ImageTargets.apk...
[2011-06-09 12:07:44 - ImageTargets] Success!
[2011-06-09 12:07:45 - ImageTargets] Starting activity com.qualcomm.QCARSamples.ImageTargets.ImageTargets on device emulator-5554
[2011-06-09 12:07:48 - ImageTargets] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.qualcomm.QCARSamples.ImageTargets/.ImageTargets }

Nothing happens after this.

I re-checked the libImageTargets.so and environment variables but again got stuck at this point.

Any help appreciated.

Thanks,
Kranti

Re: Testing ImageTargets

June 10, 2011 - 3:24am #6

Thank you very much Peter and Tyro.

I had to reinstall my device drivers after which I could see the teapot instantly! :)

Re: Testing ImageTargets

June 9, 2011 - 10:11am #5

Hello Kranti,

If you cannot find your device using DDMS or adb you may need to install device drivers or you may need to enable development on the device if you haven't done so already.

To enable development on your device goto:

Settings -> Applications -> Development -> Check "USB debugging"

You can find drivers for your device from the device manufacturers website.

-Peter

Re: Testing ImageTargets

June 9, 2011 - 9:31am #4

Does your device appear in the DDMS?

To find the DDMS, open the perspectives tab in Eclipse ( upper right ) and you can select the DDMS under 'other'. The DDMS will show you which Android devices are present and enable you to select from them.

IIRC Eclipse will prompt you to select a device, whether an AVD or an actual device, if more than one is present in the DDMS.

Re: Testing ImageTargets

June 9, 2011 - 7:00am #3

Thanks for your reply.

I have connected my device to the system on which I am running the sample code in Eclipse. But I do not understand why it is picking up the emulator and not the actual device.

How can I make it point to the actual Android device?

Re: Testing ImageTargets

June 9, 2011 - 6:14am #2

You need to use an actual device, the emulator isn't supported for QCAR. There's no camera support in the emulator.

Log in or register to post comments