Log in or register to post comments

Upgrading from SDK 0.10.0 to 1.0.0

June 15, 2011 - 3:02am #6

I have been looking around on the forum and in the Dev Guide without finding anything...

I have a application created for SDK 0.10.0 and wish to upgrade it to SDK 1.0.0.

What steps do I have to do to upgrade the QCAR SDK to the 1.0.0 edition? At the moment the application crashes when ever I start QCAR.

Re: Upgrading from SDK 0.10.0 to 1.0.0

June 16, 2011 - 5:56am #5

If looking on the sample Image Target, what steps would I need to do to upgrade it to SDK 1.0.0 from SDK 0.10.0? I am not interested of just copying files from the folder but need to know what differences that actually makes it work?

Re: Upgrading from SDK 0.10.0 to 1.0.0

June 16, 2011 - 10:15am #4

Hello Sara,

Upgrading your 0.10 project to the 1.0.0 SDK is a 4 step process:

1. *Replace the libqcar.so files in your project with the ones from 1.0.0
2. Replace the QCAR.jar file in your project with the one from 1.0.0
3. Recreate your targets at ar.qualcomm.com. Download the new targets and replace config.xml and qcar-resources.dat in the project.
4. Update the AndroidManifest.xml file to include the permissions android.permission.ACCESS_WIFI_STATE and android.permission.READ_PHONE_STATE

*The libqcar.so files are located in the libs director of your project

Let us know if you run into any issues,


Re: Upgrading from SDK 0.10.0 to 1.0.0

June 17, 2011 - 2:43am #3

Hi Peter

Still not working... But progress has been made :P

Before starting out editing my project I'm trying to do the upgrade to ImageTarget SDK 0.10.0. I follow the instructions that you gave. The project is compiled and run, the ImageTarget application is upp and running. Great! When I test with the sample images (stones and chips) the application crashes, not so good... No error message is provided.

What I did additionaly was (in eclipse):
In Builders i cleared the mark for the Import QCAR (Win)
Java Build Path: changed QCAR_SDK_ROOT so it was aimed at the C:/Development/Android/qcar-sdk-1-0-0\build\javaQCAR\QCAR.jar

So when a object is identified the application crashes at the moment, no changes has been made in the code except what mentioned earlier in you're post.

The folder .externalToolBuilders is not with in SDK 1.0.0, is this anything that is needed (I tried removing but seems to be some references to it in the code)?


Re: Upgrading from SDK 0.10.0 to 1.0.0

June 17, 2011 - 12:47pm #2

Hello Sara,

Your almost there. Sounds like there is an issue with the shared .so file. Please try the following:

1. QCAR_SDK_ROOT should point to the folder: C:/Development/Android/qcar-sdk-1-0-0

2. Be sure to run ndk-build from cygwin in your app directory first. Then in eclipse select Project -> Clean .

Let me know how it goes.


Re: Upgrading from SDK 0.10.0 to 1.0.0

June 20, 2011 - 2:35am #1

Got it working, thanks for the help!

I noticed that the libQCAR.so was not generated when I made a ndk-build so I started to look for the problem there.

I had a local directory with the build files for QCAR (my-project/build). I deleted the build folder and copied it from QCAR SDK 1.0.0 again. I copied the jni/android.mk and edited the location of the needed file. Ran ndk-build again, clean project and then it worked.

Log in or register to post comments