Log in or register to post comments

webcam authorization

December 17, 2015 - 5:02am #1

So im trying to run vuforia on unity 5.1 through 5.3, all 32bit versions but i dont get my webcam working.

i always get the error

Cannot use web cam, since the user has not authorized this!

UnityEngine.WebCamTexture:Play()
Vuforia.WebCamTexAdaptorImpl:Play()
Vuforia.WebCamImpl:StartCamera()
Vuforia.CameraDeviceImpl:StartCameraDevice()
Vuforia.CameraDeviceImpl:Start()
Vuforia.VuforiaAbstractBehaviour:StartVuforia(Boolean, Boolean)

Vuforia.VuforiaAbstractBehaviour:Start()

 

Google istn my friend today, and i dont get this working.

 

webcam authorization

March 9, 2016 - 10:40am #16

UPDATE: Vuforia 5.5.9 has been released and supports Unity 5.3.2 and 5.3.3:

https://developer.vuforia.com/library/articles/Release_Notes/Vuforia-SDK-Release-Notes

https://developer.vuforia.com/downloads/sdk

Also, make sure to check the Unity Migration Guide before upgrading to Vuforia 5.5:

https://developer.vuforia.com/library/articles/Solution/Migrating-Unity-Projects-to-Vuforia-5-5

webcam authorization

February 28, 2016 - 9:09am #15

Vuforia 5.0.10 supports Unity 5.3 up to version 5.3.1f1 and its patch releases 5.3.1p1, p2 and p3; however it does not support Unity 5.3.2 or 5.3.3;

see this:

https://developer.vuforia.com/forum/unity-extension-technical-discussion/notice-unity-532-incompatible-vuforia

so, if you are on 5.3.3, you need to either downgrade to either Unity 5.2.4f1 or 5.3.1f1;

the next release of Vuforia will support the latest Unity 5.3.3.

 

webcam authorization

February 28, 2016 - 6:25am #14

HI Team,

Much appreciated for the below help. I had downloaded the UNITY 5.3.3f1 (32 bit for windows only). Once i created my first AR project, I get the following error

Cannot use web cam, since the user has not authorized this!
UnityEngine.WebCamTexture:Play()

Is it possible to let me know the issue or do i need to revert back with previous versions, if so what is it.

 

Thanks

webcam authorization

February 12, 2016 - 9:11am #13

Yes, that's what I mentioned in my last comment, 5.1.1 and V 5.0.10 works ...but no other Unity versions work!

webcam authorization

February 12, 2016 - 9:06am #12

Sorry about the lateness of muy reply BUT I used Unity 5.1.1f1 apparently with Vuforia 5-0-10  and it worked for me!!

 

I do not know why but it works....I had other issues with the new release of Unity  too!!! (Problems with build menu.....??)

 

 

HOpe this helps others.....thanks

webcam authorization

February 9, 2016 - 10:34pm #11

I tried everything, nothing helped!

The only solution was to go back to unity 5.1.1 + Vuforia 5.0.10 .... then the cam worked finally !

webcam authorization

February 9, 2016 - 12:42pm #10

SaraAbdelkader wrote:
Cannot use web cam, since the user has not authorized this!

Check to see if you have the Android platform installed and selected in Unity's Build Settings (File > Build Settings...).

webcam authorization

February 5, 2016 - 11:57am #9

what is the version of Vuforia you used?

I have 5.0.10 and I still get the same problem

webcam authorization

February 5, 2016 - 11:46am #8

I have the same problem!

I have unity 5.3.2 (both 64 and 32) bits, but I'm running my project on 32 bits. I selected IOS and Android when I was installing. I'm using Vuforia 5.0.10 

I'm trying to run a very simple AR project just to test Vuforia and Unity. But I only gey this error

Cannot use web cam, since the user has not authorized this!
UnityEngine.WebCamTexture:Play()
Vuforia.WebCamTexAdaptorImpl:Play()
Vuforia.WebCamImpl:StartCamera()
Vuforia.CameraDeviceImpl:StartCameraDevice()
Vuforia.CameraDeviceImpl:Start()
Vuforia.VuforiaAbstractBehaviour:StartVuforia(Boolean, Boolean)
 
So please can you help me!! This is driving me crazy.

webcam authorization

January 14, 2016 - 5:08pm #7

SOLUTION:  (one that works --why I do not know)

 

I went back to UNITY 3D version 5.1.1f1personal and then added the VUforia Plug-in and that WORKED!!!

 

thank you

 

webcam authorization

January 14, 2016 - 12:01pm #6

Starting with Unity 5.3.x, you need to make sure to select the iOS and Android platforms during installation. The Vuforia Unity Plugin is a native Unity plugin and is compiled as 32-bit on Windows and 32/64-bit on Mac which means that you need to download the Unity Editor 32-bit version of Unity if running on Windows (don't download Unity Installer version as this will install it as 64-bit, not 32-bit).

If you see QCARWrapper.dll errors and warnings about 64-bit architecture in the Unity Console on Windows, then you are running 64-bit version of Unity and not 32-bit.

webcam authorization

January 14, 2016 - 3:59am #5

Guys i have found a solution!

got this working with Unity 5.3.0f 32-bit Version i think its a problem with 64-bit and 32-bit version.

webcam authorization

January 11, 2016 - 2:23pm #4

I have same problem???

webcam authorization

January 11, 2016 - 10:26am #3

Same. Any input??

webcam authorization

December 29, 2015 - 8:12am #2

Same problem here, help pls!

Log in or register to post comments