Log in or register to post comments

Cannot use web cam, since the user has not authorized this!

March 19, 2013 - 10:12am #1

Yeah, so, how do I fix this error:

 

Cannot use web cam, since the user has not authorized this!

 

I'm trying to use Play Mode on Unity Pro 3.5.7f6 (I have an iOS liscence, but I am developing on a PC).

 

I tried this: http://docs.unity3d.com/Documentation/ScriptReference/Application.RequestUserAuthorization.html?from=UserAuthorization

But that won't work, as the Vuforia script doesn't like it.

Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs(316,10): error CS1624: The body of `QCARBehaviour.Start()' cannot be an iterator block because `void' is not an iterator interface type

or if I change start from Void to IEnumerator:

Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs(316,5): error CS0246: The type or namespace name `IEnumerator' could not be found. Are you missing a using directive or an assembly reference?

 

Also, these forums suck.  They display thread posts in reverse chronological order, so opening a thread shows me "thanks, that worked!" before I even know what the details of that particular user's problems were.

Cannot use web cam, since the user has not authorized this!

June 25, 2016 - 7:49am #17

I had the same problem, but with no vuforia project (did not even load the vuforia assets into the assets folder), so I thought this is a general problem.

After short research I find the answer:

https://docs.unity3d.com/ScriptReference/Application.RequestUserAuthorization.html

And everything works fine!

For protection reasons for hacking, Unity added  a "firewall" asking user's authorization to access the webcam.

As I have read on a reply here, the upper script does not work in vuforia, but I am afraid that there is little we can do and better regard  it as "bug" both to unity and vuforia and just wait them to give solution

 

I use windows 10 x64, Unity 5.3.4f1 (64-bit)

Cannot use web cam, since the user has not authorized this!

January 12, 2016 - 5:20am #16

I using the version 4.6 64bit of unity, no bugs!

Cannot use web cam, since the user has not authorized this!

January 12, 2016 - 1:25am #15

@UlissesCAD have you tried it they way i got it work?

 

@WOW2015 as i said in my post, for me it didnt work on Unity 5.3 personal, too. Did you try what i suggested in my Post? (Unity 5.1.0 32-Bit, run as admin)

 

Greetings

Cannot use web cam, since the user has not authorized this!

January 11, 2016 - 1:27pm #14

Thanks but I tried it as administrator and that did not work...I have windows 64 bit windows 10  and the new unity and VUforia plugin stil does not work

 

 

any suggestions would be appreciated

 

UNITY is VERSION 5.3.0f4 personal

VUFORIA Plug=in 5.0.10  

 

 

oh well (actually was able to do this previously on this machine until had a virus and had to clean the machine but do not think that that affects this this time??

 

AttachmentSize
Image icon unity_webcam_ERROR.jpg250.97 KB

Cannot use web cam, since the user has not authorized this!

December 21, 2015 - 3:43am #13

I have the same problem and don t find reply.

Cannot use web cam, since the user has not authorized this!

December 19, 2015 - 6:55am #12

Unity In-editor preview (play mode) with Vuforia will only work in the 32 bit version of Unity, you can have 64 bit OS no problem, I've done this on Win 7 amd Win8. I've used Unity 5.30f4 most recently with no problems. I've also found that you can edit and build using the 64 bit version of Unity, but preview wont work, the built versions will work fine though.

NOTE: I have noticed that there are a few other things that are not so happy in the 32 Bit version of Unity, namely the EventsManager and UI namespaces seem to not register properly, so you will get compile errors under certain conditions. I've found a couple workarounds for this, but generally go and build in the 64 bit version. If you are getting errors go change a script and recompile scripts in the 64 bit version, then you should be able to load up the 32 bit version and use play mode.

ALSO NOTE: I had a really tough time figuring out that the registration of content to image targets was being offset because I had my Oculus DK2 plugged in and set off to the side, this caused my content to be offset by the rotation of the DK2, so make sure if you are not developing for DK2 immediately, remove all OVR references and unplug your DK2 to develop for Vuforia. (DK2 is good for Gear Vuforia Development btw)

-C

 

 

 

 

 

Cannot use web cam, since the user has not authorized this!

December 19, 2015 - 2:49am #11

I made it, getting it run on windows7 64-Bit with webcam on Unity Preview.

First of all you need Unity5.1.0f3 (32-Bit):

Go here https://unity3d.com/get-unity/download/archive-> Scroll down to Unity5.1.0 -> Downloads (Win) -> Unity Editor 32-Bit

Dont use an existing Project, make it complete new, reimport the assets you downloaded from vuforia.

And here is that breaking news trick i didnt found on the internet: you need to run unity as administrator! x) This will make your camera run.

Dont forget to place your 3D Object into ImageTarget as Child.

I only tried with unity5.3.0 32-bit and unity5.1.0 32-Bit when i read several times its only possible with 32 Bit Unity. But it worked only with 5.1.0 32-Bit! Since i didnt test it out it maybe that it runs with other 32-Bit versions of Unity.

Cannot use web cam, since the user has not authorized this!

December 18, 2015 - 6:33pm #10

Make sure you are set to iOS or Android for the build platform (click "switch platform" if needed)

Authorization is built into the Android manifest for android, but the default Vuforia manifest should handle this for you.

There is a way to authorize via script for Web builds, but you can't build a web build with Vuforia yet.

-C

www.wrenar.com

 

 

 

 

 

 

Cannot use web cam, since the user has not authorized this!

December 18, 2015 - 6:21pm #9

The same message was returned by Unity  yet :(
(with Vuforia 5.010 and Unity 5.3)

Cannot use web cam, since the user has not authorized this!

December 18, 2015 - 6:20pm #8

The same message was returned with Vuforia 5.010 and Unity 5.3 yet. :(

Cannot use web cam, since the user has not authorized this!

December 10, 2015 - 12:41pm #7

Here's a happy Unity 5.3 feature: The win32 version supports ONLY Web build and Desktop Platform. 

So this means Vuforia doesn't work with Unity anymore on Windows: I love Vuforia, but the number one game engine on the number one platform is not working. 

Suggestions: 

  • Support 64 bit Version of Unity on Windows.  
  • Consider supporting the Windows platform like a gajillion people on the forums for over 2 years have asked for (I was the first BTW)

Merry Xmas! 

Realized I somehow got the beta version downloaded in my attempt to get the 32 bit version installed. Once you get the release version, the platforms work again.

As for authorization, web builds require authorization in the code when you call the camera and android needs it in the manifest.  

-C

 

 

 

 

 

Cannot use web cam, since the user has not authorized this!

December 10, 2015 - 8:26am #6

how can i do to authorize camera ?

Cannot use web cam, since the user has not authorized this!

June 13, 2014 - 7:58am #5

Are you certain that you don't have the platform selected as Web Player?

It usually is related to that.

Cannot use web cam, since the user has not authorized this!

June 13, 2014 - 7:58am #4

Are you certain that you don't have the platform selected as Web Player?

It usually is related to that.

Cannot use web cam, since the user has not authorized this!

March 19, 2013 - 10:28am #3

I changed the build target, got the same error (and another, that I'd gotten before, but didn't get when I made my original post).

And yes, I'm getting it in play mode:

http://postimage.org/image/6sweo6ejn/

Cannot use web cam, since the user has not authorized this!

March 19, 2013 - 10:18am #2

You shouldn't need to request user authorization if running within the Editors Play Mode. What build are you targetting in your Player Settings? - try another.

Log in or register to post comments