Topic locked

Flikering with the camera front and BackgroundTextureAccess

July 9, 2014 - 2:55am #1

Hi,

I currently working on an application using Vuforia, and I have a problem.
I use the "BackgroundTextureAccess" method to display the background and when I use the front camera, I get a flicker between the rendering of the camera and a black screen.
I tried to load the scene of the sample BackgroundTextureAccess, set the camera on the front, then bluid, and it's reproduce the bug.
I currently work on Android, I was not able to test on IOS.

Anyone know how to fix this ?

Thanks.

Flikering with the camera front and BackgroundTextureAccess

March 30, 2015 - 11:05pm #7

the Vuforia SDK 4.0 for Mobile has been released. You can download the SDK and the Unity Extension from:

https://developer.vuforia.com/

Note: before upgrading, please read the migration guide:

https://developer-beta.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

Flikering with the camera front and BackgroundTextureAccess

January 15, 2015 - 12:56am #6

UPDATE:

the Vuforia SDK 4.0 beta (which contains the fix for the issue below) has been released. You can download SDK 4.0 Beta from:

https://developer-beta.vuforia.com/

Note: before upgrading, please read the migration guide:

https://developer-beta.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

 

A commercial (non-beta) final release of 4.0 is also expected soon (but no confirmed dates available yet).

 

Flikering with the camera front and BackgroundTextureAccess

November 10, 2014 - 3:35am #5

BTW: the proper fix for this issue should be included in the next Vuforia public release. Until then, feel free to use the simple workaround below.

 

Flikering with the camera front and BackgroundTextureAccess

July 11, 2014 - 4:24am #4

You're welcome.

Flikering with the camera front and BackgroundTextureAccess

July 11, 2014 - 3:39am #3

Works fine now !

Thank you =)

Flikering with the camera front and BackgroundTextureAccess

July 11, 2014 - 3:20am #2

Hi, this is a small sample glitch that you can correct by adding a C# script to the BackgroundCamera with this little code snippet:

    void OnPreRender()
    {
        // make sure the correct backface culling is set for this camera
        GL.SetRevertBackfacing(false);
    }

 

Topic locked