Topic has a solution and is locked
Topic locked

DllNotFoundException: VuforiaEngine.dll

Unity Editor
August 9, 2022 - 4:13pm #1
Topic solved

I'm getting this error on all unity editor versions. 



I'm on macos Big Sur 11.6.1

Help?

Platform: 

DllNotFoundException: VuforiaEngine.dll

August 25, 2022 - 6:03am #18

Okey , have a good day 

DllNotFoundException: VuforiaEngine.dll

August 11, 2022 - 6:40am #17

Hey all,

First of all, I'd like to apologize again for these stressful 48 hours. We've realized that the issue you experienced is due to an unfortunate unforeseen expired certificate.

You can fix the DLL issues by upgrading to Vuforia Engine v10.9 which was released yesterday. We're developing a workaround for developers who cannot upgrade to the new version to unblock you from the issues caused by this problem.

Please allow us some additional time to develop the workaround. I'll update this thread by the end of this work-week. You can also find more information here: https://developer.vuforia.com/forum/unity-development/vuforia-engine-v10-dll-issues-mac

Edit: I also created a video to go through the workarounds for this problem: https://www.youtube.com/watch?v=WAdEbGjk0hk

Kind regards,

Patrick Scheper

Vuforia Engine Product Manager

DllNotFoundException: VuforiaEngine.dll

August 11, 2022 - 12:55am #16

10.9.3 update seems to have fixed the problem, whatever it was.

Thank you Patrick!

 

I don't understand how could this problem, whatever it was, affect an open project overnight, with no updates or changes on my end.

It only seems to affect Apple computers, so maybe some background automatic update on Apple's part was the cause?

 

Anyway, back to work, and thanks again to everybody for their support.

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 10:21pm #15

10.9 is working for me so far.



As I posted earlier, I did get a message from MacOS saying that "vuforiaengine.bundle will damage your computer" when attempting to make a build with 10.8, I assumed it might have meant that Apple have incorrectly flagged the bundle as malware suddenly.

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 10:02am #14

Working with 10.9 for me as well.

As far as reproducing the issue, I don't know how could I help, because the steps are as simple as I've previously mentioned. Really a strange issue to occur. 

 

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 8:24am #13

Hey,

 

It is great to hear that your issue is resolved by updating to the new version, though it is not recommended because I want to try to find out why the issues appear with v10.8. So a current workaround is to upgrade to v10.9, but it would be good if anyone can confirm my previous post and provide additional comments on how to reproduce the issue with v10.8.

Thanks.

 

Kind regards,

Patrick Scheper

Vuforia Engine Product Manager

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 6:50am #12

Hello again Patrick,

The new Vuforia 10.9.3 is solving the problem! Just updating the package allowed us to continue using Vuforia on the Unity Editor.

Thank you and your team for your fast replies and update of Vuforia!

Hope it's the same for the others ;)

Have a nice day.

Kind regards from the Realillusioins Team

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 6:29am #11

Hey all,

 

Thank you for the additional posts, really is appreciated. 

Still no update from our side, though looking into it. It seems that the issue cannot be reproduced on our end.

Personally I've been using my MacBook Pro 2017 (MacOS Big Sur 11.6.1). This OS version was noted before by dinomaskot but I can't seem to reproduce the issue as well. 

My steps are:

  1. Create a new Unity project (2020.3.18f1)
  2. Download Core Samples through Package Manager / Asset Store (Engine v10.9)
  3. Import Core Samples
  4. Press Play in Unity Editor

So my questions to you all are:

  • Can you reproduce the DLL issue with my steps provided above?
    • If not, can you provide me with details on what steps to add to reproduce the issue?
  • Can you test with our newly released v10.9? We're releasing as we speak and already updated our Unity Samples. You can download the new version via the Package Manager in Unity. 

Thanks everyone. 

Kind regards,

Patrick Scheper

Vuforia Engine Product Manager

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 5:07am #10

Hello, and thank you for letting us know you are working on it.

Not one of my projects is working today, and all of them were working perfectly yesterday.

 

Mac Mini (M1, 2020)

MacOS Monterey 12.4

Unity 2021.3.6f1

Vuforia 10.8.4

 

I have been working on Unity 2021.3.6f1 when I first encountered the problem, and have since installed 2021.3.8f1, but when I try creating a new file from scratch in either version, or when I try to open projects that I know for a fact were working (some developed with 2021.3.4f1) I keep experiencing the same problems, basically Vuforia refusing to work once I've set up my scene.

When I press PLAY, all I get is a blank game view and the following error messages:

 

DllNotFoundException: VuforiaEngine.dll assembly:<unknown assembly> type:<unknown type> member:(null)

Vuforia.VuEngineConfigSet.Create () (at <e14545c7af794fc2ac732dc7dfa2ea9f>:0)

Vuforia.Internal.NativeBridge.NativeEngineConfigSet..ctor (Vuforia.VuforiaConfiguration vuforiaConfiguration) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.NativeBridge.NativeEngineConfigSet..ctor (Vuforia.VuforiaConfiguration vuforiaConfiguration, System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.NativeBridge.NativeEngineFactory.CreateEngineConfig (Vuforia.VuforiaConfiguration vuforiaConfiguration, System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.Core.Engine.Init (System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.VuforiaApplication.Initialize () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.Core.OneTimeInitialization.Initialize () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

 

And also a variant of this error

Target status: Aguila NO_POSE -- NOT_OBSERVED

UnityEngine.Debug:Log (object)

DefaultObserverEventHandler:OnObserverStatusChanged (Vuforia.ObserverBehaviour,Vuforia.TargetStatus) (at Library/PackageCache/com.ptc.vuforia.engine@9accda8169f2/Vuforia/Scripts/DefaultObserverEventHandler.cs:92)

DefaultObserverEventHandler:Start () (at Library/PackageCache/com.ptc.vuforia.engine@9accda8169f2/Vuforia/Scripts/DefaultObserverEventHandler.cs:61)

 

Again, thank you and I hope you find the problem soon.

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 4:53am #9

Hello Patrick,

The problem happens on macOS computers, not Windows in our case and only in Unity Editor (compilation working fine).

Old or new macOS version is the same (we are on 12.5 Monterey).

The problem is in both our Apple Silicon and Intel Macs.

We are using Unity 2021.3.8f1 and the problem is also on 2021.3.7f1, 2021.3.6f1 and 2022.1.12f1.

The version of Vuforia we are using is the 10.8.4 who was working fine until tomorrow in our case.

We also tested creating a new project with the core sample and the same problem happens in the Editor.

 

Kind regards,

Realillusions Team

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 4:46am #8

Macbook Pro retina 15" late 2013 (i7, no dedicated GPU)

MacOS 11.6.1

U 2021.3.8f1

V 10.8.4

Just tried the Core Samples and still the same.

Steps to reproduce:

- Create new project (3d core)

- Add Vuforia package

- Play

Resulting in error: 

DllNotFoundException: VuforiaEngine.dll assembly:<unknown assembly> type:<unknown type> member:(null)

Vuforia.VuEngineConfigSet.Create () (at <e14545c7af794fc2ac732dc7dfa2ea9f>:0)

Vuforia.Internal.NativeBridge.NativeEngineConfigSet..ctor (Vuforia.VuforiaConfiguration vuforiaConfiguration) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.NativeBridge.NativeEngineConfigSet..ctor (Vuforia.VuforiaConfiguration vuforiaConfiguration, System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.NativeBridge.NativeEngineFactory.CreateEngineConfig (Vuforia.VuforiaConfiguration vuforiaConfiguration, System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.Core.Engine.Init (System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.VuforiaApplication.Initialize () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.Core.OneTimeInitialization.Initialize () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 4:28am #7

Hey everyone,

 

Just wanting to update you that we're reading your posts and are working to find a solution. Sadly I am not aware of where the problem might come from.

Could you please share all information you can share?

  • Device specification
  • OS version
  • Unity version
  • Vuforia Engine version

It would be also good if you could share that information and also provide feedback on what happens when you create a new Unity project and add our Core Samples to it. 

Thank you and apologies for any difficulties this might cause.

 

Kind regards,

Patrick Scheper

Vuforia Engine Product Manager

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 3:21am #6

That's exactly it, Vuforia just stopped working overnight :(

I tried to open 6 different projects, no luck. They were all working yesterday,

Has this happened before?? 

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 3:12am #5

Me too, same thing as described by others : Vuforia stopped working.

I'm on Unity 2021.3.8f1 and Vuforia 10.8.4

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 3:10am #4

Hello,

Same problem for me since I opened my project yesterday. I'm on 2021.3.8f1 Apple Silicon and Vuforia 10.8.4.

When I build for iOS it's working but not in the Editor

DllNotFoundException: VuforiaEngine.dll

August 10, 2022 - 2:55am #3

Please I need help!

I'm currently working on an AR app, yesterday it was working fine, but this morning when I tried to run it I get this message:

 

DllNotFoundException: VuforiaEngine.dll assembly:<unknown assembly> type:<unknown type> member:(null)

Vuforia.VuEngineConfigSet.Create () (at <e14545c7af794fc2ac732dc7dfa2ea9f>:0)

Vuforia.Internal.NativeBridge.NativeEngineConfigSet..ctor (Vuforia.VuforiaConfiguration vuforiaConfiguration) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.NativeBridge.NativeEngineConfigSet..ctor (Vuforia.VuforiaConfiguration vuforiaConfiguration, System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.NativeBridge.NativeEngineFactory.CreateEngineConfig (Vuforia.VuforiaConfiguration vuforiaConfiguration, System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.Core.Engine.Init (System.String recordingPath) (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.VuforiaApplication.Initialize () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.Internal.Core.OneTimeInitialization.Initialize () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

 

It's baffling to me, how can a project that was working yesterday, without having changed anything at all, it doesn't even activate the cam when I press play now, all I get is that error!

Also older projects developed in 2021.3.4f1 that I still had open were working without any problem, but now that I have restarted Unity they give me the same error! 

Sorry for my english, and please I will welcome any suggestions, thx!

 

MacOs Monterrey 12.4

My app was developed using Unity 2021.3.6f1 (Silicon) and Vuforia 10.8.4, but when I installed the newer version editor 2021.2.8f1 the problem remains when building a new scene.

 

 

DllNotFoundException: VuforiaEngine.dll

August 9, 2022 - 5:14pm #2

I'm getting the exact same error. Unity Engine 2021.3.0f1. Mac Monterey 12.5



I got an error earlier from Mac when I originally attempted the build - "vuforiaengine.bundle will damage your computer". That second error hasn't popped up again but I'm still getting the error below.



DllNotFoundException: VuforiaEngine.dll assembly:<unknown assembly> type:<unknown type> member:(null)

Vuforia.VuEngine.GetBuildPreset () (at <e14545c7af794fc2ac732dc7dfa2ea9f>:0)

Vuforia.Internal.Core.Engine.GetBuildPreset () (at <fc0527c2c5e144b7a3ac68f447d51940>:0)

Vuforia.EditorClasses.ConfigureForPrivateBuildTask.Execute () (at <ecefe24ca6274b29a05906456681d74f>:0)

BuildObserver+<>c.<OnPreprocessBuild>b__3_0 (Vuforia.EditorClasses.VuforiaLifeCycleTask t) (at <ecefe24ca6274b29a05906456681d74f>:0)

System.Collections.Generic.List`1[T].ForEach (System.Action`1[T] action) (at <e38a6d3ee47c43eb9b2e49c63fc0aa48>:0)

BuildObserver.OnPreprocessBuild (UnityEditor.Build.Reporting.BuildReport report) (at <ecefe24ca6274b29a05906456681d74f>:0)

UnityEditor.Build.BuildPipelineInterfaces+<>c__DisplayClass16_0.<OnBuildPreProcess>b__1 (UnityEditor.Build.IPreprocessBuildWithReport bpp) (at /Users/bokken/buildslave/unity/build/Editor/Mono/BuildPipeline/BuildPipelineInterfaces.cs:436)

UnityEditor.Build.BuildPipelineInterfaces.InvokeCallbackInterfacesPair[T1,T2] (System.Collections.Generic.List`1[T] oneInterfaces, System.Action`1[T] invocationOne, System.Collections.Generic.List`1[T] twoInterfaces, System.Action`1[T] invocationTwo, System.Boolean exitOnFailure) (at /Users/bokken/buildslave/unity/build/Editor/Mono/BuildPipeline/BuildPipelineInterfaces.cs:402)

UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&) (at /Users/bokken/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:189)

Topic locked