Topic locked

ImageTarget stopped working 10.6.3

Unity Editor
April 12, 2022 - 4:56am #1

Hello everyone,

I'm currently working on a project that involves ImageTargets with Vuforia, Unity(2020.3.24f) and the Hololens 2. I had Vuforia 10.5.5 installed a couple of days ago and everything worked fine but decided to upgrade to 10.6.3. However since the upgrade the HoloLens 2 stopped detecting my targets. 

What I've done in the troubleshooting process:

  • Double checked my project settings 

  • ProjectSettings

    ProjectSettings 2

  • Double checked the ARcamera


  • Target Experience Scale set: World
  • ImageTarget Transform set pos: (0,0,0)
  • Also double-checked my build settings:


  • Also tried upgrading Unity to 2020.3.33f1

    I'm really lost on what to do. Any suggestions are appreciated.


    So I finally got it working. I had to rollback to Vuforia 9.8.11. Using Unity 2020.3.24f1. What am I missing in the new version 10.6.3? Or is it a bug?



    Found a version of Vuforia 10.5.5 in my downloads folder. Update to that version again and everything worked like a charm.



    Switched to what I belive is the right forum: from feature > Image to Device [...] -> Unity Development 

Image icon 134305.png60.78 KB
Image icon 134633.png32.43 KB
Image icon ARcamera.png34.57 KB
Image icon build.png50.48 KB

ImageTarget stopped working 10.6.3

April 17, 2022 - 11:33pm #3

Thank you for your reply. Since everything is working now with the version 10.5.5 I wont dare to touch it again. I will test it out later on in the project when time is no longer a factor. 

ImageTarget stopped working 10.6.3

April 15, 2022 - 9:49am #2


First suggestion is to try building our Core Samples for HoloLens: These are tested with every release, so it could help to provide a basis for debugging.

Kind regards,

Dave Downing

Vuforia Engine Technical Support

Topic locked